aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-02-07 04:39:07 +0800
committeroliver <oliver@FreeBSD.org>2007-02-07 04:39:07 +0800
commita608665677fad6b726a5ff6e24d6f43f8100845b (patch)
treeeffeb9fc974aa0e2daed0cc48d5947a445f83af1 /x11-wm/xfce4
parentb17a9530001683d64b324f6a85b5f66131dc1850 (diff)
downloadfreebsd-ports-gnome-a608665677fad6b726a5ff6e24d6f43f8100845b.tar.gz
freebsd-ports-gnome-a608665677fad6b726a5ff6e24d6f43f8100845b.tar.zst
freebsd-ports-gnome-a608665677fad6b726a5ff6e24d6f43f8100845b.zip
propper style to fit into Mk/ directory where I hope it will go verry soon
Diffstat (limited to 'x11-wm/xfce4')
-rw-r--r--x11-wm/xfce4/bsd.xfce.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/xfce4/bsd.xfce.mk b/x11-wm/xfce4/bsd.xfce.mk
index 820426b8256a..f3e1b45fa7b2 100644
--- a/x11-wm/xfce4/bsd.xfce.mk
+++ b/x11-wm/xfce4/bsd.xfce.mk
@@ -1,3 +1,20 @@
+#
+# $FreeBSD$
+#
+
+.if !defined(_POSTMKINCLUDED) && !defined(Xfce_Pre_Include)
+
+Xfce_Pre_Include= bsd.xfce.mk
+Xfce_Include_MAINTAINER= oliver@FreeBSD.org
+
+# This file contains some variable definitions that are supposed to
+# make your life easier when dealing with ports related to the Xfce
+# desktop environment. It's automatically included when USE_XFCE
+# is defined in the ports' makefile.
+
+_USE_XFCE_ALL= configenv libexo libgui libutil libmcs mcsmanager panel \
+ thunar wm xfdev
+
MASTER_SITE_SUBDIR?= xfce-4.4.0
configenv_CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
@@ -22,9 +39,23 @@ wm_RUN_DEPENDS= xfwm4:${PORTSDIR}/x11-wm/xfce4-wm
xfdev_RUN_DEPENDS= xfce4-dev-tools:${PORTSDIR}/devel/xfce4-dev-tools
+.endif
+
+.if defined(_POSTMKINCLUDED) && !defined(Xfce_Post_Include)
+
+Xfce_Post_Include= bsd.xfce.mk
+
.for component in ${USE_XFCE}
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
CONFIGURE_ENV+= ${${component}_CONFIGURE_ENV}
.endfor
+
+.for component in ${USE_XFCE}
+. if ${_USE_XFCE_ALL:M${component}}==""
+IGNORE= cannot install: Unknown component ${component}
+. endif
+.endfor
+
+.endif