aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorarrowd <arrowd@FreeBSD.org>2018-09-27 23:43:12 +0800
committerarrowd <arrowd@FreeBSD.org>2018-09-27 23:43:12 +0800
commit032586d9269d0f1cee350118582b428baa0de1b0 (patch)
treec8db4858f8abe61d8404f21b9aea6f8191eb1b0c /x11-wm
parent12bcc7139e5c44917f46b32945b96c10b351871d (diff)
downloadfreebsd-ports-gnome-032586d9269d0f1cee350118582b428baa0de1b0.tar.gz
freebsd-ports-gnome-032586d9269d0f1cee350118582b428baa0de1b0.tar.zst
freebsd-ports-gnome-032586d9269d0f1cee350118582b428baa0de1b0.zip
x11-wm/xmonad: Update to 0.14.
PR: 231750 Submitted by: Kevin Zheng <kevinz5000@gmail.com> Approved by: tcberner (mentor)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/hs-xmonad/Makefile3
-rw-r--r--x11-wm/hs-xmonad/distinfo6
-rw-r--r--x11-wm/hs-xmonad/files/patch-8.4.1-support61
3 files changed, 4 insertions, 66 deletions
diff --git a/x11-wm/hs-xmonad/Makefile b/x11-wm/hs-xmonad/Makefile
index 4405c557628c..acb261843558 100644
--- a/x11-wm/hs-xmonad/Makefile
+++ b/x11-wm/hs-xmonad/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xmonad
-PORTVERSION= 0.13
-PORTREVISION= 4
+PORTVERSION= 0.14
CATEGORIES= x11-wm haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/x11-wm/hs-xmonad/distinfo b/x11-wm/hs-xmonad/distinfo
index c5c0fb45f0e3..05d33c215730 100644
--- a/x11-wm/hs-xmonad/distinfo
+++ b/x11-wm/hs-xmonad/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486836802
-SHA256 (cabal/xmonad-0.13.tar.gz) = f9f81b63569f18c777a939741024ec3ae34e4ec84015e5cc50f6622034a303ca
-SIZE (cabal/xmonad-0.13.tar.gz) = 72034
+TIMESTAMP = 1538002916
+SHA256 (cabal/xmonad-0.14.tar.gz) = a456d091373e8d5cd7635917171763b1216814aea4a476b9ceb9cb7315980353
+SIZE (cabal/xmonad-0.14.tar.gz) = 65744
diff --git a/x11-wm/hs-xmonad/files/patch-8.4.1-support b/x11-wm/hs-xmonad/files/patch-8.4.1-support
deleted file mode 100644
index 2dcf5baf645b..000000000000
--- a/x11-wm/hs-xmonad/files/patch-8.4.1-support
+++ /dev/null
@@ -1,61 +0,0 @@
---- src/XMonad/Core.hs.orig 2017-02-09 02:46:45 UTC
-+++ src/XMonad/Core.hs
-@@ -39,6 +39,7 @@ import qualified Control.Exception.Extensible as E
- import Control.Applicative
- import Control.Monad.State
- import Control.Monad.Reader
-+import Data.Semigroup
- import Data.Default
- import System.FilePath
- import System.IO
-@@ -56,7 +57,7 @@ import Graphics.X11.Xlib.Extras (getWindowAttributes,
- import Data.Typeable
- import Data.List ((\\))
- import Data.Maybe (isJust,fromMaybe)
--import Data.Monoid
-+import Data.Monoid hiding ((<>))
-
- import qualified Data.Map as M
- import qualified Data.Set as S
-@@ -151,6 +152,9 @@ instance Applicative X where
- pure = return
- (<*>) = ap
-
-+instance Semigroup a => Semigroup (X a) where
-+ (<>) = liftM2 (<>)
-+
- instance (Monoid a) => Monoid (X a) where
- mempty = return mempty
- mappend = liftM2 mappend
-@@ -164,6 +168,9 @@ newtype Query a = Query (ReaderT Window X a)
-
- runQuery :: Query a -> Window -> X a
- runQuery (Query m) w = runReaderT m w
-+
-+instance Semigroup a => Semigroup (Query a) where
-+ (<>) = liftM2 (<>)
-
- instance Monoid a => Monoid (Query a) where
- mempty = return mempty
---- xmonad.cabal.orig 2017-02-10 22:07:40 UTC
-+++ xmonad.cabal
-@@ -32,7 +32,8 @@ tested-with:
- GHC==7.6.3,
- GHC==7.8.4,
- GHC==7.10.3,
-- GHC==8.0.1
-+ GHC==8.0.1,
-+ GHC==8.2.2
-
- data-files: man/xmonad.hs, man/xmonad.1, man/xmonad.1.html
-
-@@ -78,7 +79,8 @@ library
- process,
- unix,
- utf8-string >= 0.3 && < 1.1,
-- X11>=1.8 && < 1.9
-+ X11>=1.8 && < 1.9,
-+ semigroups
-
- if true
- ghc-options: -funbox-strict-fields -Wall