aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-17 17:00:59 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-17 17:00:59 +0800
commit13b9db40303e31ef5f2b4efad0623940a7d75c75 (patch)
tree39bbb933d13496ecfda673678be3688d6b3750ce /x11-wm
parentd65b1706fc4fb6c1a48e163dfa5c0f4fb53ca57b (diff)
downloadfreebsd-ports-gnome-13b9db40303e31ef5f2b4efad0623940a7d75c75.tar.gz
freebsd-ports-gnome-13b9db40303e31ef5f2b4efad0623940a7d75c75.tar.zst
freebsd-ports-gnome-13b9db40303e31ef5f2b4efad0623940a7d75c75.zip
- Pet portlint
- Switch to options helpers - Regenerate patches - Update WWW Approved by: portmgr blanket
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/e-module-mem/Makefile16
-rw-r--r--x11-wm/e-module-mem/files/patch-src-e_mod_main.c7
-rw-r--r--x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c13
-rw-r--r--x11-wm/e-module-mem/pkg-descr2
4 files changed, 14 insertions, 24 deletions
diff --git a/x11-wm/e-module-mem/Makefile b/x11-wm/e-module-mem/Makefile
index 7783983ea4b7..f4f47948ab3f 100644
--- a/x11-wm/e-module-mem/Makefile
+++ b/x11-wm/e-module-mem/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-wm enlightenment
MASTER_SITES= LOCAL/gblach/enlightenment/
+DIST_SUBDIR= enlightenment
MAINTAINER= enlightenment@FreeBSD.org
COMMENT= Enlightenment memory monitoring module
@@ -14,7 +15,6 @@ COMMENT= Enlightenment memory monitoring module
BUILD_DEPENDS= enlightenment:x11-wm/enlightenment
RUN_DEPENDS= enlightenment:x11-wm/enlightenment
-DIST_SUBDIR= enlightenment
GNU_CONFIGURE= yes
USES= gmake libtool pkgconfig tar:xz
INSTALL_TARGET= install-strip
@@ -22,16 +22,8 @@ INSTALL_TARGET= install-strip
.include "../enlightenment/Makefile.plist"
OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.mk>
diff --git a/x11-wm/e-module-mem/files/patch-src-e_mod_main.c b/x11-wm/e-module-mem/files/patch-src-e_mod_main.c
index 277054f8ed5c..1ebaef750fe7 100644
--- a/x11-wm/e-module-mem/files/patch-src-e_mod_main.c
+++ b/x11-wm/e-module-mem/files/patch-src-e_mod_main.c
@@ -1,7 +1,6 @@
-diff -ur src.old/e_mod_main.c src/e_mod_main.c
---- src.old/e_mod_main.c 2010-11-13 17:56:21.000000000 +0200
-+++ src/e_mod_main.c 2012-02-21 23:43:46.548797357 +0200
-@@ -424,11 +424,9 @@
+--- src/e_mod_main.c.orig 2014-09-23 14:36:23 UTC
++++ src/e_mod_main.c
+@@ -422,11 +422,9 @@ _mem_cb_check (void *data)
if (!inst->ci->show_percent)
{
diff --git a/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c b/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c
index 5b14b15912c9..dd4028bd5f63 100644
--- a/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c
+++ b/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c
@@ -1,6 +1,5 @@
-diff -ur src.old/machdep_freebsd.c src/machdep_freebsd.c
---- src.old/machdep_freebsd.c 2010-11-13 17:56:21.000000000 +0200
-+++ src/machdep_freebsd.c 2012-02-21 23:18:00.000000000 +0200
+--- src/machdep_freebsd.c.orig 2014-09-23 14:36:23 UTC
++++ src/machdep_freebsd.c
@@ -12,6 +12,8 @@
#define GETSYSCTL(name, var) getsysctl(name, &(var), sizeof (var))
@@ -10,7 +9,7 @@ diff -ur src.old/machdep_freebsd.c src/machdep_freebsd.c
static int
getsysctl (char *name, void *ptr, size_t len)
{
-@@ -32,7 +34,6 @@
+@@ -32,7 +34,6 @@ getsysctl (char *name, void *ptr, size_t
static int
swapinfo (int *total, int *used)
{
@@ -18,7 +17,7 @@ diff -ur src.old/machdep_freebsd.c src/machdep_freebsd.c
size_t mibsize, size;
struct xswdev xsw;
int mib[16], n;
-@@ -61,8 +62,8 @@
+@@ -61,8 +62,8 @@ swapinfo (int *total, int *used)
return 1;
}
@@ -29,7 +28,7 @@ diff -ur src.old/machdep_freebsd.c src/machdep_freebsd.c
*total += tmp_total;
*used += tmp_used;
}
-@@ -82,8 +83,6 @@
+@@ -82,8 +83,6 @@ _mem_get_values (ci, phys_used, sw_used,
{
int total_pages, inactive_pages, free_pages;
@@ -38,7 +37,7 @@ diff -ur src.old/machdep_freebsd.c src/machdep_freebsd.c
if (GETSYSCTL ("vm.stats.vm.v_page_count", total_pages))
{
warnx ("can't read sysctl \"vm.stats.vm.v_page_count\"");
-@@ -102,8 +101,8 @@
+@@ -102,8 +101,8 @@ _mem_get_values (ci, phys_used, sw_used,
return;
}
diff --git a/x11-wm/e-module-mem/pkg-descr b/x11-wm/e-module-mem/pkg-descr
index 8cc800356702..2a755187fd07 100644
--- a/x11-wm/e-module-mem/pkg-descr
+++ b/x11-wm/e-module-mem/pkg-descr
@@ -2,4 +2,4 @@ An E17 module which monitors the RAM usage. It features the following:
- display text and/or graph
- display text in percentage or absolute
-WWW: http://www.enlightenment.org
+WWW: https://www.enlightenment.org/