aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2018-05-20 21:47:08 +0800
committerzeising <zeising@FreeBSD.org>2018-05-20 21:47:08 +0800
commit193287b7d26db9c4283068a3f84fc06c5b7b5c1d (patch)
treeb2312c11bdad2cf4d77bb131329d3e883e590044 /x11-wm
parent93fb47ad5006daa4b231c06906dfa764d89fceed (diff)
downloadfreebsd-ports-gnome-193287b7d26db9c4283068a3f84fc06c5b7b5c1d.tar.gz
freebsd-ports-gnome-193287b7d26db9c4283068a3f84fc06c5b7b5c1d.tar.zst
freebsd-ports-gnome-193287b7d26db9c4283068a3f84fc06c5b7b5c1d.zip
x11-wm/xcompmgr: Add patch to fix shadow rendering
The patch has been laying in upstream bugzilla for quite some time, but is used on some linux distribution packages, such as debian packages. While here, add missing dependency on xext. PR: 182002 Submitted by: Brandon Gooch Obtained from: https://bugs.freedesktop.org/show_bug.cgi?id=46285 (patch) MFH: 2018Q2
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xcompmgr/Makefile3
-rw-r--r--x11-wm/xcompmgr/files/patch-xcompmgr.c28
2 files changed, 30 insertions, 1 deletions
diff --git a/x11-wm/xcompmgr/Makefile b/x11-wm/xcompmgr/Makefile
index 2562d5c7620f..2d96d6c665b9 100644
--- a/x11-wm/xcompmgr/Makefile
+++ b/x11-wm/xcompmgr/Makefile
@@ -3,13 +3,14 @@
PORTNAME= xcompmgr
PORTVERSION= 1.1.7
+PORTREVISION= 1
CATEGORIES= x11-wm
MAINTAINER= x11@FreeBSD.org
COMMENT= Sample X compositing manager
XORG_CAT= app
-USE_XORG= x11 xcomposite xfixes xdamage xrender
+USE_XORG= x11 xcomposite xext xfixes xdamage xrender
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
diff --git a/x11-wm/xcompmgr/files/patch-xcompmgr.c b/x11-wm/xcompmgr/files/patch-xcompmgr.c
new file mode 100644
index 000000000000..91f2ad186da5
--- /dev/null
+++ b/x11-wm/xcompmgr/files/patch-xcompmgr.c
@@ -0,0 +1,28 @@
+--- xcompmgr.c.orig 2015-04-17 05:56:17 UTC
++++ xcompmgr.c
+@@ -1028,7 +1028,6 @@ paint_all (Display *dpy, XserverRegion region)
+ {
+ w->borderClip = XFixesCreateRegion (dpy, NULL, 0);
+ XFixesCopyRegion (dpy, w->borderClip, region);
+- XFixesIntersectRegion(dpy, w->borderClip, w->borderClip, w->borderSize);
+ }
+ w->prev_trans = t;
+ t = w;
+@@ -1080,6 +1079,8 @@ paint_all (Display *dpy, XserverRegion region)
+ if (w->mode == WINDOW_TRANS)
+ {
+ int x, y, wid, hei;
++ XFixesIntersectRegion(dpy, w->borderClip, w->borderClip, w->borderSize);
++ XFixesSetPictureClipRegion(dpy, rootBuffer, 0, 0, w->borderClip);
+ #if HAS_NAME_WINDOW_PIXMAP
+ x = w->a.x;
+ y = w->a.y;
+@@ -1099,6 +1100,8 @@ paint_all (Display *dpy, XserverRegion region)
+ else if (w->mode == WINDOW_ARGB)
+ {
+ int x, y, wid, hei;
++ XFixesIntersectRegion(dpy, w->borderClip, w->borderClip, w->borderSize);
++ XFixesSetPictureClipRegion(dpy, rootBuffer, 0, 0, w->borderClip);
+ #if HAS_NAME_WINDOW_PIXMAP
+ x = w->a.x;
+ y = w->a.y;