aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /x11-wm
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/e17-modules/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/x11-wm/e17-modules/Makefile b/x11-wm/e17-modules/Makefile
index 7aebd3fb7cb3..a2512aca9b37 100644
--- a/x11-wm/e17-modules/Makefile
+++ b/x11-wm/e17-modules/Makefile
@@ -12,7 +12,7 @@ COMMENT= Meta-port for e17 modules
NO_BUILD= yes
WANT_EFL= yes
-E17_ARCH= ${OPSYS:L}${OSREL}-${ARCH}
+E17_ARCH= ${OPSYS:tl}${OSREL}-${ARCH}
MODULES= alarm comp-scale cpu deskshow diskio eektool elfe empris engage eooorg \
everything-aspell everything-mpris everything-pidgin everything-places \
@@ -28,19 +28,19 @@ EVERYTHING_SHOTGUN_PATH= evry-shotgun
EVERYTHING_WEBSEARCH_PATH= evry-websearch
.for M in ${MODULES}
-OPTIONS_DEFINE+= ${M:U:S,-,_,g}
-OPTIONS_DEFAULT+= ${M:U:S,-,_,g}
-${M:U:S,-,_,g}_DESC= Install ${M} module
+OPTIONS_DEFINE+= ${M:tu:S,-,_,g}
+OPTIONS_DEFAULT+= ${M:tu:S,-,_,g}
+${M:tu:S,-,_,g}_DESC= Install ${M} module
.endfor
.include <bsd.port.options.mk>
.for M in ${MODULES}
-. if !defined(${M:U:S,-,_,g}_PATH)
-${M:U:S,-,_,g}_PATH= ${M}
+. if !defined(${M:tu:S,-,_,g}_PATH)
+${M:tu:S,-,_,g}_PATH= ${M}
. endif
-. if ${PORT_OPTIONS:M${M:U:S,-,_,g}}
-RUN_DEPENDS+= ${LOCALBASE}/lib/enlightenment/modules/${${M:U:S,-,_,g}_PATH}/${E17_ARCH}/module.so:${PORTSDIR}/x11-wm/e17-module-${M}
+. if ${PORT_OPTIONS:M${M:tu:S,-,_,g}}
+RUN_DEPENDS+= ${LOCALBASE}/lib/enlightenment/modules/${${M:tu:S,-,_,g}_PATH}/${E17_ARCH}/module.so:${PORTSDIR}/x11-wm/e17-module-${M}
. endif
.endfor