aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2013-11-01 07:57:27 +0800
committergarga <garga@FreeBSD.org>2013-11-01 07:57:27 +0800
commit249f3a5404de6babd4e68a35fdcad3d035eb5146 (patch)
tree294f3729d1f3876242ddb599d482b09a5bd2c30b /x11-wm
parentbd455b8230ddfead844e7831c5936597bac08c33 (diff)
downloadfreebsd-ports-gnome-249f3a5404de6babd4e68a35fdcad3d035eb5146.tar.gz
freebsd-ports-gnome-249f3a5404de6babd4e68a35fdcad3d035eb5146.tar.zst
freebsd-ports-gnome-249f3a5404de6babd4e68a35fdcad3d035eb5146.zip
. Simplify Makefile
. Add missing dependency: gdkpixbuf2 . Bump PORTREVISION
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index ec8e3d6e55b3..465b7adf9e72 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -3,6 +3,7 @@
PORTNAME= awesome
PORTVERSION= 3.5.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-wm
MASTER_SITES= http://awesome.naquadah.org/download/
@@ -36,7 +37,7 @@ USE_XZ= yes
USES= cmake iconv pkgconfig
CMAKE_ARGS+= -DSYSCONFDIR=${PREFIX}/etc
USE_EFL= imlib2
-USE_GNOME= glib20 pango
+USE_GNOME= glib20 pango gdkpixbuf2
USE_LUA= 5.1+
USE_XORG= pixman x11 xau xcb xdmcp xext xft xinerama xrandr xrender \
xproto
@@ -47,6 +48,10 @@ PORTDOCS= AUTHORS BUGS LICENSE README
OPTIONS_DEFINE= DBUS DOCS
OPTIONS_DEFAULT=DBUS DOCS
+DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+DBUS_CMAKE_ON= -DWITH_DBUS=YES
+DBUS_CMAKE_OFF= -DWITH_DBUS=NO
+
.include <bsd.port.pre.mk>
.if (exists(${LOCALBASE}/libdata/pkgconfig/cairo.pc) && \
@@ -54,19 +59,6 @@ OPTIONS_DEFAULT=DBUS DOCS
IGNORE= cannot find dependency: The cairo exists but not with XCB support. Please reinstall graphics/cairo with XCB support
.endif
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS += libdbus-1.so:${PORTSDIR}/devel/dbus
-CMAKE_ARGS += -DWITH_DBUS=YES
-.else
-CMAKE_ARGS += -DWITH_DBUS=NO
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-CMAKE_ARGS += -DINSTALL_PORTDOCS=YES -DGENERATE_DOC=YES
-.else
-CMAKE_ARGS += -DINSTALL_PORTDOCS=NO -DGENERATE_DOC=NO
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "/LUA_EXECUTABLE lua/ s,lua,lua-${LUA_VER}," \
${WRKSRC}/awesomeConfig.cmake