aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-20 00:45:47 +0800
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-20 00:45:47 +0800
commit3a971e8679b8429919bc985a6810194bc2f0c4b6 (patch)
tree8378b88cdf14068d43eecdf9f26e6abf1587d353 /x11-wm
parent3624ddf181da71b2f213d44844a13f92e7088879 (diff)
downloadfreebsd-ports-gnome-3a971e8679b8429919bc985a6810194bc2f0c4b6.tar.gz
freebsd-ports-gnome-3a971e8679b8429919bc985a6810194bc2f0c4b6.tar.zst
freebsd-ports-gnome-3a971e8679b8429919bc985a6810194bc2f0c4b6.zip
OBApps is a graphical tool for configuring the per-application settings
(window matching) in the Openbox window manager. OBApps uses ~/.config/openbox/rc.xml (or the config-file Openbox was started with) by default. You can specify another file as an argument, e.g. obapps.py .config/openbox/myrc.xml Enter or change the name, class, role, or type settings by clicking in their entries in the listbox. Using the Find button to get settings by clicking on a window changes the settings for the CURRENTLY SELECTED item in the listbox; it does not add a new entry unless nothing is highlighted. You'll usually want to use the New button to create a new item first. Blank entries for name/class/role/type are ignored. If you want any of those fields to be stored as literally blank attributes (e.g. to match only a window with a blank role), enter "" or '' in the field. Changes are written to the rc.xml file only when the apply button is used. Openbox will automatically be reconfigured when this is done. WWW: http://sourceforge.net/apps/mediawiki/obapps/index.php PR: ports/179667 Submitted by: nemysis (self) Approved by: pawel (mentor)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/obapps/Makefile37
-rw-r--r--x11-wm/obapps/distinfo4
-rw-r--r--x11-wm/obapps/pkg-descr24
-rw-r--r--x11-wm/obapps/pkg-plist5
5 files changed, 71 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 5d198adee223..8530a8908b0a 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -117,6 +117,7 @@
SUBDIR += musca
SUBDIR += mutter
SUBDIR += nickleby
+ SUBDIR += obapps
SUBDIR += obconf
SUBDIR += obkey
SUBDIR += obmenu
diff --git a/x11-wm/obapps/Makefile b/x11-wm/obapps/Makefile
new file mode 100644
index 000000000000..3dfad3a9a8eb
--- /dev/null
+++ b/x11-wm/obapps/Makefile
@@ -0,0 +1,37 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= obapps
+PORTVERSION= 0.1.7
+CATEGORIES= x11-wm
+MASTER_SITES= SF/${PORTNAME}/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Graphical editor for Openbox application settings
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlib>=0:${PORTSDIR}/x11-toolkits/py-xlib
+
+USE_PYTHON= yes
+USE_WX= 2.8+
+WX_COMPS= python:run
+USE_PYDISTUTILS=yes
+
+PORTDOCS= README
+
+DESKTOP_ENTRIES="OBApps" "${COMMENT}" ${PORTNAME} \
+ "${PORTNAME}" "Settings;" false
+
+post-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/obapps/distinfo b/x11-wm/obapps/distinfo
new file mode 100644
index 000000000000..6d644211f31b
--- /dev/null
+++ b/x11-wm/obapps/distinfo
@@ -0,0 +1,4 @@
+SHA256 (obapps-0.1.7.tar.gz) = 34b9135677d697839f5e498d87ef39af306e917216c9a5dd0ef64905547194f6
+SIZE (obapps-0.1.7.tar.gz) = 7252
+SHA256 (obapps.png) = 8aa5dcb736fee2f8a2a1f62fded60f57d18b063f5b5f48eb11480464e8dc214e
+SIZE (obapps.png) = 3504
diff --git a/x11-wm/obapps/pkg-descr b/x11-wm/obapps/pkg-descr
new file mode 100644
index 000000000000..5f00fa4d6f5f
--- /dev/null
+++ b/x11-wm/obapps/pkg-descr
@@ -0,0 +1,24 @@
+OBApps is a graphical tool for configuring the per-application settings
+(window matching) in the Openbox window manager.
+
+OBApps uses ~/.config/openbox/rc.xml
+(or the config-file Openbox was started with) by default.
+You can specify another file as an argument, e.g.
+ obapps.py .config/openbox/myrc.xml
+
+Enter or change the name, class, role, or type settings by clicking in their
+entries in the listbox.
+
+Using the Find button to get settings by clicking on a window changes the
+settings for the CURRENTLY SELECTED item in the listbox; it does not add
+a new entry unless nothing is highlighted. You'll usually want to use the New
+button to create a new item first.
+
+Blank entries for name/class/role/type are ignored. If you want any of those
+fields to be stored as literally blank attributes (e.g. to match only a window
+with a blank role), enter "" or '' in the field.
+
+Changes are written to the rc.xml file only when the apply button is used.
+Openbox will automatically be reconfigured when this is done.
+
+WWW: http://sourceforge.net/apps/mediawiki/obapps/index.php
diff --git a/x11-wm/obapps/pkg-plist b/x11-wm/obapps/pkg-plist
new file mode 100644
index 000000000000..c37f26131bd3
--- /dev/null
+++ b/x11-wm/obapps/pkg-plist
@@ -0,0 +1,5 @@
+bin/obapps
+%%PYTHON_SITELIBDIR%%/obaxutils.py
+%%PYTHON_SITELIBDIR%%/obaxutils.pyc
+%%PYTHON_SITELIBDIR%%/obaxutils.pyo
+share/pixmaps/obapps.png