aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2007-05-27 11:03:31 +0800
committerkris <kris@FreeBSD.org>2007-05-27 11:03:31 +0800
commit3ee20a81fbe38cbba4000ad893e1ac81e953f2eb (patch)
tree965567cbb664ce2d1956915bd4daa13e8e6e1241 /x11-wm
parent0ccd4067feff5266b8b5bc29943d9c4ca415e847 (diff)
downloadfreebsd-ports-gnome-3ee20a81fbe38cbba4000ad893e1ac81e953f2eb.tar.gz
freebsd-ports-gnome-3ee20a81fbe38cbba4000ad893e1ac81e953f2eb.tar.zst
freebsd-ports-gnome-3ee20a81fbe38cbba4000ad893e1ac81e953f2eb.zip
BROKEN with gcc 4.2
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/epiwm/Makefile8
-rw-r--r--x11-wm/fluxspace/Makefile4
-rw-r--r--x11-wm/jewel/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/x11-wm/epiwm/Makefile b/x11-wm/epiwm/Makefile
index edccfc39f832..687f3447290b 100644
--- a/x11-wm/epiwm/Makefile
+++ b/x11-wm/epiwm/Makefile
@@ -26,6 +26,12 @@ DOCS= AUTHORS BUGS COPYING ChangeLog EPIwm-0.5.6.lsm INSTALL NEWS \
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
${REINPLACE_CMD} 's|/etc/X11/epiwm|${PREFIX}/etc/epiwm|' \
${WRKSRC}/configure
@@ -38,4 +44,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/fluxspace/Makefile b/x11-wm/fluxspace/Makefile
index a5dab4b52705..a5d6fee9796a 100644
--- a/x11-wm/fluxspace/Makefile
+++ b/x11-wm/fluxspace/Makefile
@@ -28,6 +28,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if defined(WITH_IDESK) || exists(${X11BASE}/bin/idesk)
RUN_DEPENDS+= idesk:${PORTSDIR}/x11/idesk
.endif
diff --git a/x11-wm/jewel/Makefile b/x11-wm/jewel/Makefile
index 26dacbd6f286..869410f003e9 100644
--- a/x11-wm/jewel/Makefile
+++ b/x11-wm/jewel/Makefile
@@ -23,6 +23,12 @@ PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
@${SED} -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g ; \
@@ -50,4 +56,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>