aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-10-30 03:36:13 +0800
committerflz <flz@FreeBSD.org>2007-10-30 03:36:13 +0800
commit5b06351886a5793438b77f9a551609ca64afb110 (patch)
treed1e7600922d92a7050caa5be53a0e5d07e409511 /x11-wm
parent98e24b063ff9a0bcbc1221809fe3937304cef515 (diff)
downloadfreebsd-ports-gnome-5b06351886a5793438b77f9a551609ca64afb110.tar.gz
freebsd-ports-gnome-5b06351886a5793438b77f9a551609ca64afb110.tar.zst
freebsd-ports-gnome-5b06351886a5793438b77f9a551609ca64afb110.zip
Add patch from git.
Submitted by: maintainer
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/emerald/Makefile1
-rw-r--r--x11-wm/emerald/files/patch-src_main.c48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
index c8447630501f..3bcd63febfbb 100644
--- a/x11-wm/emerald/Makefile
+++ b/x11-wm/emerald/Makefile
@@ -7,6 +7,7 @@
PORTNAME= emerald
PORTVERSION= 0.5.2
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
diff --git a/x11-wm/emerald/files/patch-src_main.c b/x11-wm/emerald/files/patch-src_main.c
new file mode 100644
index 000000000000..d8b6e5160b58
--- /dev/null
+++ b/x11-wm/emerald/files/patch-src_main.c
@@ -0,0 +1,48 @@
+--- src/main.c.orig 2007-08-12 17:00:01.000000000 -0400
++++ src/main.c 2007-10-29 15:27:28.000000000 -0400
+@@ -3477,11 +3477,11 @@
+ WnckWindow *win;
+ decor_t *d;
+
+- win = wnck_screen_get_active_window(screen);
++ win = wnck_screen_get_previously_active_window(screen);
+ if (win)
+ {
+ d = g_object_get_data(G_OBJECT(win), "decor");
+- if (d->pixmap && d->decorated)
++ if (d && d->pixmap && d->decorated)
+ {
+ d->active = wnck_window_is_active(win);
+ d->fs = (d->active ? d->fs->ws->fs_act : d->fs->ws->fs_inact);
+@@ -3493,11 +3493,11 @@
+ }
+ }
+
+- win = wnck_screen_get_previously_active_window(screen);
++ win = wnck_screen_get_active_window(screen);
+ if (win)
+ {
+ d = g_object_get_data(G_OBJECT(win), "decor");
+- if (d->pixmap && d->decorated)
++ if (d && d->pixmap && d->decorated)
+ {
+ d->active = wnck_window_is_active(win);
+ d->fs = (d->active ? d->fs->ws->fs_act : d->fs->ws->fs_inact);
+@@ -3558,6 +3558,8 @@
+ if (!get_window_prop(wnck_window_get_xid(win), select_window_atom, &window))
+ remove_frame_window(win);
+
++ g_object_set_data (G_OBJECT (win), "decor", NULL);
++
+ g_free(d);
+ }
+
+@@ -5567,7 +5569,7 @@
+
+ if (status != DECOR_ACQUIRE_STATUS_SUCCESS)
+ {
+- if (status == DECOR_ACQUIRE_STATUS_OTHER_DM_RUNNING)
++ if (status == DECOR_ACQUIRE_STATUS_FAILED)
+ {
+ fprintf (stderr,
+ "%s: Could not acquire decoration manager "