aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2013-09-06 02:20:35 +0800
committergblach <gblach@FreeBSD.org>2013-09-06 02:20:35 +0800
commit89a97e81aca125118e02d3621c3d34f2b2fabf8c (patch)
tree90b4f36b90fd4f2193e1b2047ced438bf2413585 /x11-wm
parent7b8d80687d8581f9534dad1c771deb6b53b29b76 (diff)
downloadfreebsd-ports-gnome-89a97e81aca125118e02d3621c3d34f2b2fabf8c.tar.gz
freebsd-ports-gnome-89a97e81aca125118e02d3621c3d34f2b2fabf8c.tar.zst
freebsd-ports-gnome-89a97e81aca125118e02d3621c3d34f2b2fabf8c.zip
- Fix freeze when splash screen is enabled
- Bump PORTREVISION Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Makefile1
-rw-r--r--x11-wm/enlightenment/files/patch-src-bin-e_main.c34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Makefile b/x11-wm/enlightenment/Makefile
index 2e28a4b444e0..547272bc9bd5 100644
--- a/x11-wm/enlightenment/Makefile
+++ b/x11-wm/enlightenment/Makefile
@@ -3,6 +3,7 @@
PORTNAME= enlightenment
PORTVERSION= 0.17.4
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= x11-wm enlightenment
MASTER_SITES= http://download.enlightenment.fr/releases/ \
diff --git a/x11-wm/enlightenment/files/patch-src-bin-e_main.c b/x11-wm/enlightenment/files/patch-src-bin-e_main.c
new file mode 100644
index 000000000000..0aa2a707f948
--- /dev/null
+++ b/x11-wm/enlightenment/files/patch-src-bin-e_main.c
@@ -0,0 +1,34 @@
+--- src/bin/e_main.c.orig
++++ src/bin/e_main.c
+@@ -462,15 +462,6 @@ main(int argc, char **argv)
+ TS("E_Alert Init Done");
+ _e_main_shutdown_push(e_alert_shutdown);
+
+- TS("E_Xinerama Init");
+- if (!e_xinerama_init())
+- {
+- e_error_message_show(_("Enlightenment cannot initialize E_Xinerama!\n"));
+- _e_main_shutdown(-1);
+- }
+- TS("E_Xinerama Init Done");
+- _e_main_shutdown_push(e_xinerama_shutdown);
+-
+ TS("E_Hints Init");
+ e_hints_init();
+ TS("E_Hints Init Done");
+@@ -521,6 +512,15 @@ main(int argc, char **argv)
+ _e_main_shutdown_push(e_randr_shutdown);
+ TS("E_Randr Init Done");
+
++ TS("E_Xinerama Init");
++ if (!e_xinerama_init())
++ {
++ e_error_message_show(_("Enlightenment cannot initialize E_Xinerama!\n"));
++ _e_main_shutdown(-1);
++ }
++ TS("E_Xinerama Init Done");
++ _e_main_shutdown_push(e_xinerama_shutdown);
++
+ TS("E_Env Init");
+ if (!e_env_init())
+ {