aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-29 02:58:46 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-29 02:58:46 +0800
commita4c47e59045ba7f79d7aa0d678385a834365e013 (patch)
tree663acecaa1538b1cb2147ae0f814b0f6e45c3768 /x11-wm
parent361e850527186853fffb97239e3d8cbc12f3cf08 (diff)
downloadfreebsd-ports-gnome-a4c47e59045ba7f79d7aa0d678385a834365e013.tar.gz
freebsd-ports-gnome-a4c47e59045ba7f79d7aa0d678385a834365e013.tar.zst
freebsd-ports-gnome-a4c47e59045ba7f79d7aa0d678385a834365e013.zip
- fix build for png-1.4.1
PR: 145117
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/pekwm/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index 99744d090346..6e2e7e085401 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -32,4 +32,14 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -liconv"
MAN1= pekwm.1
MANCOMPRESSED= no
+# replace calls to obsolete libpng12 functions
+post-extract:
+ ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|; \
+ s|png_check_sig(sig, PImageLoaderPng::PNG_SIG_BYTES) !=|png_sig_cmp(sig, 0, PImageLoaderPng::PNG_SIG_BYTES) ==|' \
+ ${WRKSRC}/src/PImageLoaderPng.cc
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|libpng12|libpng14|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>