aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-09-24 16:43:01 +0800
committertrevor <trevor@FreeBSD.org>2003-09-24 16:43:01 +0800
commitaf12904a0ed7e232142c4f904ada573609e72ae1 (patch)
treeac256f11e29b61df893387548e179365f40fefa1 /x11-wm
parent62cd03d604201108f9b19bae8de4f62ed932c77a (diff)
downloadfreebsd-ports-gnome-af12904a0ed7e232142c4f904ada573609e72ae1.tar.gz
freebsd-ports-gnome-af12904a0ed7e232142c4f904ada573609e72ae1.tar.zst
freebsd-ports-gnome-af12904a0ed7e232142c4f904ada573609e72ae1.zip
Install libobparser and libobrender shared libraries.
noticed by: Andrew J. Caines of halplant.com and Hendrik Scholz of raisdorf.net Install openbox.desktop.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 7085ebf3050e..329085076fc9 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -8,6 +8,7 @@
PORTNAME= openbox
PORTVERSION= 0.3.0.1
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://icculus.org/openbox/releases/
DISTNAME= openbox-3.0-beta1
@@ -55,6 +56,11 @@ pre-install:
| ${SED} -e 's:^:@dirrm share/openbox/:' >> ${PLIST}
cd ${WRKSRC}/data && ${FIND} -s * -type f \
| ${SED} -e 's:^:share/openbox/:' >> ${PLIST}
+ ${ECHO_CMD} share/gnome/wm-properties/openbox.desktop >> ${PLIST}
+.for ii in la so so.0
+ ${ECHO_CMD} lib/libobparser.${ii} >> ${PLIST}
+ ${ECHO_CMD} lib/libobrender.${ii} >> ${PLIST}
+.endfor
.if !defined(NOPORTDOCS)
.for ii in ${DOCS}
${ECHO_CMD} share/doc/openbox/${ii} >> ${PLIST}
@@ -72,6 +78,13 @@ do-install:
${PREFIX}/bin
cd ${WRKSRC} && pax -r -w data themes ${PREFIX}/share/openbox/
cd ${WRKSRC} && ${INSTALL_DATA} data/* ${PREFIX}/share/openbox/
+ cd ${WRKSRC} && ${INSTALL_DATA} data/openbox.desktop \
+ ${PREFIX}/share/gnome/wm-properties/
+.for ii in la so so.0
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} parser/.libs/libobparser.${ii} ${PREFIX}/lib \
+ && ${INSTALL_DATA} render/.libs/libobrender.${ii} ${PREFIX}/lib
+.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for ii in ${DOCS}