aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 21:48:09 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 21:48:09 +0800
commitb3beda7f9832825ce3d30b216f34ef6ff62a0a6d (patch)
tree7f2015e660decea25af7368fb596b9bf3e67ba7b /x11-wm
parentb1c5f262f7f930c5d6a08ea7606d8bfa98f176c7 (diff)
downloadfreebsd-ports-gnome-b3beda7f9832825ce3d30b216f34ef6ff62a0a6d.tar.gz
freebsd-ports-gnome-b3beda7f9832825ce3d30b216f34ef6ff62a0a6d.tar.zst
freebsd-ports-gnome-b3beda7f9832825ce3d30b216f34ef6ff62a0a6d.zip
x11-wm/jewel: Fix build with Clang 6
windowmanager.cc:1929:24: error: non-constant-expression cannot be narrowed from type 'int' to 'CARD32' (aka 'unsigned long') in initializer list [-Wc++11-narrowing] CARD32 geometry[] = { xres, yres }; ^~~~ windowmanager.cc:1929:24: note: insert an explicit cast to silence this issue CARD32 geometry[] = { xres, yres }; ^~~~ static_cast<CARD32>( ) http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/jewel-0.12.41_4.log - Make sure the build respects CXXFLAGS
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/jewel/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-wm/jewel/Makefile b/x11-wm/jewel/Makefile
index fa9b9bd95b0f..83a9e527780b 100644
--- a/x11-wm/jewel/Makefile
+++ b/x11-wm/jewel/Makefile
@@ -16,8 +16,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ALL_TARGET= all
DOCS= Changelog Changelog.DLR Changelog.jewel INSTALL LICENSE README
PORTDOCS= *
-USES+= gmake
+USES= compiler gmake
USE_XORG= x11 xext xpm
+MAKE_ARGS= CFLAGS="${CXXFLAGS}"
+
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
OPTIONS_DEFINE= DOCS