aboutsummaryrefslogtreecommitdiffstats
path: root/x11/9box/files
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-24 03:45:43 +0800
committeroliver <oliver@FreeBSD.org>2003-07-24 03:45:43 +0800
commita1241e4e332353a94c4b267db6851e53c7f4b867 (patch)
treeeb0b8d0589f7274c5a3223dc0e4cdc550709eced /x11/9box/files
parent6366ae8f6cdde2ea6786b66c3e818136fc950c7f (diff)
downloadfreebsd-ports-gnome-a1241e4e332353a94c4b267db6851e53c7f4b867.tar.gz
freebsd-ports-gnome-a1241e4e332353a94c4b267db6851e53c7f4b867.tar.zst
freebsd-ports-gnome-a1241e4e332353a94c4b267db6851e53c7f4b867.zip
Add 9box 0.2.1, 9box can "pack" windows inside itself.
PR: 50172 Submitted by: Serge Gagnon <gagnon__s@videotron.ca>
Diffstat (limited to 'x11/9box/files')
-rw-r--r--x11/9box/files/patch-src::Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11/9box/files/patch-src::Makefile b/x11/9box/files/patch-src::Makefile
new file mode 100644
index 000000000000..6391a9423197
--- /dev/null
+++ b/x11/9box/files/patch-src::Makefile
@@ -0,0 +1,19 @@
+--- src/Makefile.orig Tue Oct 29 17:20:46 2002
++++ src/Makefile Wed Jul 23 21:35:39 2003
+@@ -1,10 +1,14 @@
++CC?= cc
++CFLAGS+= -g -I. -I%%X11BASE%%/include
++LIBS+= -L%%X11BASE%%/lib -lX11
++
+ all: 9box
+
+ 9box: grab.o 9box.o manage.o menu.o buttons.o utils.o wm.o
+- gcc -g -L/usr/X11R6/lib -lX11 -o $@ $^
++ $(CC) $(CFLAGS) $(LIBS) -o $@ $^
+
+ %.o: %.c
+- gcc -g -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ clean:
+ rm -f *.o 9box *~