aboutsummaryrefslogtreecommitdiffstats
path: root/x11/XFree86-4-libraries
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2002-07-19 04:30:22 +0800
committeranholt <anholt@FreeBSD.org>2002-07-19 04:30:22 +0800
commit7c6534363ec9839ed83bcc7eac6ca2fa5916be1c (patch)
tree6b0ed6cebd184a97bc0fd63a5d5ef11d13c2852e /x11/XFree86-4-libraries
parent48c68e6fd6fafef9078c9ee9822279ffa9e003cb (diff)
downloadfreebsd-ports-gnome-7c6534363ec9839ed83bcc7eac6ca2fa5916be1c.tar.gz
freebsd-ports-gnome-7c6534363ec9839ed83bcc7eac6ca2fa5916be1c.tar.zst
freebsd-ports-gnome-7c6534363ec9839ed83bcc7eac6ca2fa5916be1c.zip
Make XFree86-4 miniports use imake-4's HasXdmAuth setting (default is YES).
Clean up Wraphelp.c inclusion in the ports that need it. Add USE_PERL5 to imake-4. Approved by: des
Diffstat (limited to 'x11/XFree86-4-libraries')
-rw-r--r--x11/XFree86-4-libraries/Makefile8
-rw-r--r--x11/XFree86-4-libraries/scripts/configure38
2 files changed, 11 insertions, 35 deletions
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index b74044242e1e..838d911e67f6 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -39,8 +39,7 @@ MTREE_FILE= /etc/mtree/BSD.x11-4.dist
INSTALLS_SHLIB= yes
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
-SCRIPTS_ENV= HasXdmAuth=${HasXdmAuth} \
- HasSecureRPC=${HasSecureRPC} \
+SCRIPTS_ENV= HasSecureRPC=${HasSecureRPC} \
BuildPexExt=${BuildPexExt} \
BuildXinerama=${BuildXinerama} \
BuildXIE=${BuildXIE} \
@@ -59,7 +58,6 @@ MAN3= Xaw.3 Xft.3
# ---
# Name Default Meaning
# ----------------------------------------------------------------------------
-# HasXdmAuth YES support XDM-AUTHORIZATION-1.
# HasSecureRPC YES build with SecureRPC (require FreeBSD-3 or later)
# BuildPexExt YES build PEX extension
# BuildXinerama YES build Xinerama extension
@@ -70,7 +68,6 @@ MAN3= Xaw.3 Xft.3
# ----------------------------------------------------------------------------
# DEFAULT means ports will use values which set by ${PORTSDIR}/devel/imake-4
#
-HasXdmAuth?= YES
HasSecureRPC?= DEFAULT
BuildPexExt?= DEFAULT
BuildXinerama?= DEFAULT
@@ -89,6 +86,9 @@ PLIST_SUB+= OSMESA:="@comment "
PLIST_SUB+= OSMESA:=""
.endif
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.c ${WRKSRC}/lib/Xdmcp/
+
post-patch:
cd ${WRKSRC}/nls; \
for i in Compose XI18N_OBJS XLC_LOCALE; do \
diff --git a/x11/XFree86-4-libraries/scripts/configure b/x11/XFree86-4-libraries/scripts/configure
index eb98efd99287..22dd71a0b148 100644
--- a/x11/XFree86-4-libraries/scripts/configure
+++ b/x11/XFree86-4-libraries/scripts/configure
@@ -1,14 +1,14 @@
#!/bin/sh
-# This scripts work as following:
-# (1) cp current xf86site.def (it may be created by imake-4 ports)
+# This script does the following:
+# (1) cp current xf86site.def (it is created by the imake-4 port)
# to ${WRKDIR}/xc/config/cf.
-# this means this ports use imake-4's config defaultly.
+# this means this port uses imake-4's config for defaults.
# (2) Generate temporal config for compiling.
# Some configs, such as `ForceNormalLib', `FreeBSDBuildXprog', are
-# used for compiling this ports localy. so these configs will be generated
-# this scripts. these configs will be add to `host.def' file.
-# but this host.def will never install. use local only.
+# used locally for compiling this port, so these configs will be generated
+# by this script. These configs will be stored to the `host.def' file,
+# but this host.def will never be installed.
ORIGDEF=$PREFIX/lib/X11/config/xf86site.def
DESTDEF=$WRKDIR/xc/config/cf/xf86site.def
@@ -73,33 +73,9 @@ configure () {
echo "#define FreeBSDBuildXlib YES" >> $LOCALDEF
echo "#define FreeBSDBuildXbin NO" >> $LOCALDEF
- HasXdmAuth=YES
-
- cpwh=NO
- if [ $HasXdmAuth = YES ]; then
- WH=$WRKDIR/xc/lib/Xdmcp/Wraphelp.c
- if [ -f $WH ] ; then
- cpwh=SOURCE
- elif [ -f $DISTDIR/xc/Wraphelp.c ] ; then
- cpwh=$DISTDIR/xc/Wraphelp.c
- else
- echo "==> You must fetch USA-legal Wraphelp.c manually"
- echo "==> and put it to ${DISTDIR}/xc/."
- exit 1
- fi
- if [ X$cpwh != XNO -a X$cpwh != XSOURCE ]; then
- tr -d '\r' < $cpwh > $WH
- fi
- fi
-
# Copy ORIGDEF to DESTDEF
rm -f $DESTDEF
- grep -v '#define.*HasXdmAuth' $ORIGDEF >> $DESTDEF
- if [ $cpwh = NO ] ; then
- echo "#define HasXdmAuth NO" >> $DESTDEF
- else
- echo "#define HasXdmAuth YES" >> $DESTDEF
- fi
+ cp -f $ORIGDEF $DESTDEF
# copy generated config to host.def
cp -f $LOCALDEF $HOSTDEF