aboutsummaryrefslogtreecommitdiffstats
path: root/x11/cool-retro-term
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-10-05 06:40:28 +0800
committerMark Linimon <linimon@FreeBSD.org>2019-10-05 06:40:28 +0800
commit3f8327acdba19cae940bf817169e31062eca9e46 (patch)
tree34cca250bf3266d79d22fe45d8f0ba2bf00a9b0d /x11/cool-retro-term
parentacf07777e792dcd30cc9fba5b0f7f1741053499c (diff)
downloadfreebsd-ports-gnome-3f8327acdba19cae940bf817169e31062eca9e46.tar.gz
freebsd-ports-gnome-3f8327acdba19cae940bf817169e31062eca9e46.tar.zst
freebsd-ports-gnome-3f8327acdba19cae940bf817169e31062eca9e46.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for architecture
as a stand-in for "are we running on gcc". (PR 239181) As a side-effect, adding the stanza MAKE_ENV= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT} obviates the need for hardcoding definitions for CC, CXX, and CPP (later linimon testing). PR: 239181 Approved by: danfe (maintainer-timeout, > 2 months)
Diffstat (limited to 'x11/cool-retro-term')
-rw-r--r--x11/cool-retro-term/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11/cool-retro-term/Makefile b/x11/cool-retro-term/Makefile
index f854579cfdd9..3948c5f95d1e 100644
--- a/x11/cool-retro-term/Makefile
+++ b/x11/cool-retro-term/Makefile
@@ -16,7 +16,7 @@ GH_ACCOUNT= Swordfish90
GH_PROJECT= qmltermwidget:qtw
GH_TAGNAME= 0.2.0:qtw
-USES= gmake gl qmake qt:5
+USES= compiler gmake gl qmake qt:5
USE_GL= gl
USE_QT= qmake_build buildtools_build core declarative gui \
network sql widgets graphicaleffects_run \
@@ -24,12 +24,11 @@ USE_QT= qmake_build buildtools_build core declarative gui \
.include <bsd.port.pre.mk>
-.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+.if ${CHOSEN_COMPILER_TYPE} == gcc
USE_GCC= yes
.else
-CC= clang
-CXX= clang++
-CPP= clang-cpp
+BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
+MAKE_ENV= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT}
.endif
post-extract: