aboutsummaryrefslogtreecommitdiffstats
path: root/x11/decurs
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-07 09:38:09 +0800
committerMark Linimon <linimon@FreeBSD.org>2019-04-07 09:38:09 +0800
commit7d11ad8d62e3a79f7ad9a21f4a11a6c72d21d96a (patch)
tree627c5013bc83c023acf02a3af3e065fce831df94 /x11/decurs
parentdbf7b367bada6874e943cd6b1321f519bba71c6c (diff)
downloadfreebsd-ports-gnome-7d11ad8d62e3a79f7ad9a21f4a11a6c72d21d96a.tar.gz
freebsd-ports-gnome-7d11ad8d62e3a79f7ad9a21f4a11a6c72d21d96a.tar.zst
freebsd-ports-gnome-7d11ad8d62e3a79f7ad9a21f4a11a6c72d21d96a.zip
Include stdarg.h in src/cppstring.cpp to fix build with GCC-based
architectures: /usr/local/include/gtkmm-2.0/glibmm/thread.h: In function 'void Glib::thread_init(GThreadFunctions*)': Also add USES=dos2unix (to fix patching cppstring.cpp) gnome. PR: 237040 Submitted by: Piotr Kubaj
Diffstat (limited to 'x11/decurs')
-rw-r--r--x11/decurs/Makefile3
-rw-r--r--x11/decurs/files/patch-src_cppstring.cc10
2 files changed, 12 insertions, 1 deletions
diff --git a/x11/decurs/Makefile b/x11/decurs/Makefile
index 730951fc15e4..f3c4c7ad7e05 100644
--- a/x11/decurs/Makefile
+++ b/x11/decurs/Makefile
@@ -17,7 +17,8 @@ USE_GITHUB= yes
GH_ACCOUNT= danfe
GH_TAGNAME= 10c5691
-USES= pkgconfig
+USES= compiler:c++11-lang dos2unix gnome pkgconfig
+DOS2UNIX_FILES= src/cppstring.cc
GNU_CONFIGURE= yes
USE_XORG= x11
USE_GNOME= gtk20
diff --git a/x11/decurs/files/patch-src_cppstring.cc b/x11/decurs/files/patch-src_cppstring.cc
new file mode 100644
index 000000000000..c0dd8bb28799
--- /dev/null
+++ b/x11/decurs/files/patch-src_cppstring.cc
@@ -0,0 +1,10 @@
+--- src/cppstring.cc.orig 2019-04-05 11:08:03 UTC
++++ src/cppstring.cc
+@@ -4,6 +4,7 @@
+ #include "cppstring.hh"
+ #include "idefs.h"
+ #include <iostream>
++#include <stdarg.h>
+ // #include <except.h>
+ #define DEF_BUFFER_SIZE 512
+ #define CPPSTRING_ERROR(obj,msg,retval) {obj<<"*** ERROR *** : "<<msg<<std::endl;return retval;}