aboutsummaryrefslogtreecommitdiffstats
path: root/x11/deforaos-keyboard/Makefile
diff options
context:
space:
mode:
authorolivier <olivier@FreeBSD.org>2017-01-02 22:58:29 +0800
committerolivier <olivier@FreeBSD.org>2017-01-02 22:58:29 +0800
commit69a60f8a529ab8beba363d19643fd452cd97b820 (patch)
tree8432d9f8843bd21e1449ccea9a3616e36d2fc296 /x11/deforaos-keyboard/Makefile
parentbcd9bd5c530198a5aa2c3741b8fb40d135c7ec9a (diff)
downloadfreebsd-ports-gnome-69a60f8a529ab8beba363d19643fd452cd97b820.tar.gz
freebsd-ports-gnome-69a60f8a529ab8beba363d19643fd452cd97b820.tar.zst
freebsd-ports-gnome-69a60f8a529ab8beba363d19643fd452cd97b820.zip
Update to 0.3.1
Approved by: jadawin (mentor) Differential Revision: https://reviews.freebsd.org/D8987
Diffstat (limited to 'x11/deforaos-keyboard/Makefile')
-rw-r--r--x11/deforaos-keyboard/Makefile39
1 files changed, 31 insertions, 8 deletions
diff --git a/x11/deforaos-keyboard/Makefile b/x11/deforaos-keyboard/Makefile
index 59a2b951d37b..dabec6be3205 100644
--- a/x11/deforaos-keyboard/Makefile
+++ b/x11/deforaos-keyboard/Makefile
@@ -2,23 +2,46 @@
# $FreeBSD$
PORTNAME= keyboard
-PORTVERSION= 0.2.1
-PORTREVISION= 3
+PORTVERSION= 0.3.1
CATEGORIES= x11
-MASTER_SITES= http://www.defora.org/os/download/download/3696/
+MASTER_SITES= http://www.defora.org/os/download/download/4453/
PKGNAMEPREFIX= deforaos-
DISTNAME= Keyboard-${PORTVERSION}
MAINTAINER= olivier@FreeBSD.org
-COMMENT= DeforaOS desktop virtual keyboardr
+COMMENT= DeforaOS desktop virtual keyboard
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libDesktop.so:x11/deforaos-libdesktop
+LIB_DEPENDS= libDesktop.so:x11/deforaos-libdesktop \
+ libSystem.so:devel/deforaos-libsystem \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-USE_GNOME= gtk20
-USES= desktop-file-utils gettext pkgconfig
-USE_XORG= xtst
+USE_GNOME= gtk20 cairo gdkpixbuf2
+USES= desktop-file-utils pkgconfig
+USE_XORG= x11 xtst
MAKE_ARGS+= PREFIX=${PREFIX}
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+
+DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
+
+post-patch-DOCS-off:
+ ${REINPLACE_CMD} 's|data doc include|data include|' \
+ ${WRKSRC}/Makefile
+
+post-patch-NLS-off:
+ ${REINPLACE_CMD} 's|include po src|include src|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/keyboardctl \
+ ${STAGEDIR}${PREFIX}/bin/keyboard \
+ ${STAGEDIR}${PREFIX}/lib/Desktop/widget/keyboard.so
+
.include <bsd.port.mk>