aboutsummaryrefslogtreecommitdiffstats
path: root/x11/dmenu
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-22 16:16:07 +0800
committerbapt <bapt@FreeBSD.org>2013-03-22 16:16:07 +0800
commit585c8a6ae1e9af6cd6b5b6cf169015af3814e03b (patch)
tree0eed80486c0c9ee317000732b7da17a2b76db9f5 /x11/dmenu
parent170f3db0c400763a4a07eadc79e7abfece921b1c (diff)
downloadfreebsd-ports-gnome-585c8a6ae1e9af6cd6b5b6cf169015af3814e03b.tar.gz
freebsd-ports-gnome-585c8a6ae1e9af6cd6b5b6cf169015af3814e03b.tar.zst
freebsd-ports-gnome-585c8a6ae1e9af6cd6b5b6cf169015af3814e03b.zip
Convert to new options framework left unconverted ports in x* categories
Diffstat (limited to 'x11/dmenu')
-rw-r--r--x11/dmenu/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/x11/dmenu/Makefile b/x11/dmenu/Makefile
index 30c021294a33..213ab1445b0d 100644
--- a/x11/dmenu/Makefile
+++ b/x11/dmenu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dmenu
-# Date created: August 4, 2006
-# Whom: Jeroen Schot <schot@a-eskwadraat.nl>
-#
+# Created by: Jeroen Schot <schot@a-eskwadraat.nl>
# $FreeBSD$
-#
PORTNAME= dmenu
PORTVERSION= 4.5
@@ -21,8 +17,8 @@ COMMENT= X11 menu application designed for the dwm window manager
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= XINERAMA "Enable Xinerama support" On \
- XFT "Enable Xft support" Off
+OPTIONS_DEFINE= XINERAMA XFT
+OPTIONS_DEFAULT= XINERAMA
USE_XORG= x11
@@ -31,11 +27,11 @@ PLIST_FILES= bin/dmenu bin/dmenu_run bin/stest
.include <bsd.port.options.mk>
-.if defined(WITH_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
.endif
-.if defined(WITH_XFT)
+.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
PATCHFILES+= ${PORTNAME}-${PORTVERSION}-xft.diff
.endif
@@ -45,7 +41,7 @@ post-patch:
-e "s,%%PREFIX%%,${PREFIX},g" \
-e "s,%%LOCALBASE%%,${LOCALBASE},g" \
-e "s,%%MANPREFIX%%,${MANPREFIX},g"
-.if defined(WITHOUT_XINERAMA)
+.if ! ${PORT_OPTIONS:MXINERAMA}
@${REINPLACE_CMD} -e 's,$${XINERAMALIBS},,g' \
-e 's,$${XINERAMAFLAGS},,g' ${WRKSRC}/config.mk
.endif