aboutsummaryrefslogtreecommitdiffstats
path: root/x11/eaglemode
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-08-24 08:11:22 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-08-24 08:11:22 +0800
commit35801e440d3a47a86bbe749e57deb1150272d7e4 (patch)
tree410f002f05b37f1cf9f2611e7e2fd3f182471de5 /x11/eaglemode
parente6bdf5d52f2eeafaf6fa2c5ae2bdb0b825108a4f (diff)
downloadfreebsd-ports-gnome-35801e440d3a47a86bbe749e57deb1150272d7e4.tar.gz
freebsd-ports-gnome-35801e440d3a47a86bbe749e57deb1150272d7e4.tar.zst
freebsd-ports-gnome-35801e440d3a47a86bbe749e57deb1150272d7e4.zip
- Switch to options helpers
- Update to 0.89.1
Diffstat (limited to 'x11/eaglemode')
-rw-r--r--x11/eaglemode/Makefile57
-rw-r--r--x11/eaglemode/distinfo4
2 files changed, 24 insertions, 37 deletions
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 837f88b58b56..3bbf096fd19b 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= eaglemode
-PORTVERSION= 0.89.0
-PORTREVISION= 1
+PORTVERSION= 0.89.1
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -35,9 +34,16 @@ PORTDATA= *
OPTIONS_DEFINE= XINE RSVG PDF
OPTIONS_DEFAULT=XINE RSVG PDF
+OPTIONS_SUB= yes
+
RSVG_DESC= SVG support through librsvg
PDF_DESC= PDF support through poppler-glib
+XINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
+RSVG_USE= GNOME=librsvg2
+PDF_LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
+PDF_USE= GNOME=gtk20
+
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
@@ -45,43 +51,24 @@ USE_GCC= yes
.endif
.if ${PORT_OPTIONS:MXINE}
-LIB_DEPENDS+= libxine.so:${PORTSDIR}/multimedia/libxine
BUILD_ARGS+= xine-inc-dir="${LOCALBASE}/include" \
xine-lib-dir="${LOCALBASE}/lib"
-PLIST_SUB+= EMAV=""
-.else
-PLIST_SUB+= EMAV="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MRSVG}
-USE_GNOME+= librsvg2
-PLIST_SUB+= EMSVG=""
-.else
-PLIST_SUB+= EMSVG="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPDF}
-LIB_DEPENDS+= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
-USE_GNOME+= gtk20
-PLIST_SUB+= EMPDF=""
-.else
-PLIST_SUB+= EMPDF="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|"-O2"|"${CFLAGS}"|' \
${WRKSRC}/makers/unicc/plugins/unicc_gnu.pm
-.if ! ${PORT_OPTIONS:MXINE}
+ @${FIND} ${WRKSRC} -name "*.pl" | ${XARGS} \
+ ${REINPLACE_CMD} -e '1s|${perl_OLD_CMD}|${perl_CMD}|'
+
+post-patch-XINE-off:
@${RM} -f ${WRKSRC}/makers/emAv.maker.pm
-.endif
-.if ! ${PORT_OPTIONS:MRSVG}
+
+post-patch-RSVG-off:
@${RM} -f ${WRKSRC}/makers/emSvg.maker.pm
-.endif
-.if ! ${PORT_OPTIONS:MPDF}
+
+post-patch-PDF-off:
@${RM} -f ${WRKSRC}/makers/emPdf.maker.pm
-.endif
- @${FIND} ${WRKSRC} -name "*.pl" | ${XARGS} \
- ${REINPLACE_CMD} -e '1s|${perl_OLD_CMD}|${perl_CMD}|'
do-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
@@ -95,14 +82,14 @@ do-install:
${STAGEDIR}${PREFIX}/lib/eaglemode/lib/*.so \
${STAGEDIR}${PREFIX}/lib/eaglemode/lib/emClock/emTimeZonesProc \
${STAGEDIR}${PREFIX}/lib/eaglemode/lib/emTmpConv/emTmpConvProc
-.if ${PORT_OPTIONS:MXINE}
+
+do-install-XINE-on:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/eaglemode/lib/emAv/emAvServerProc_xine
-.endif
-.if ${PORT_OPTIONS:MRSVG}
+
+do-install-RSVG-on:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/eaglemode/lib/emSvg/emSvgServerProc
-.endif
-.if ${PORT_OPTIONS:MPDF}
+
+do-install-PDF-on:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/eaglemode/lib/emPdf/emPdfServerProc
-.endif
.include <bsd.port.post.mk>
diff --git a/x11/eaglemode/distinfo b/x11/eaglemode/distinfo
index bfc9c6797719..54e755c48865 100644
--- a/x11/eaglemode/distinfo
+++ b/x11/eaglemode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (eaglemode-0.89.0.tar.bz2) = 916a198ffb7d4d77cdfb79c020df085603db9cad49eeb9b58a5fac0e12292ea2
-SIZE (eaglemode-0.89.0.tar.bz2) = 4931577
+SHA256 (eaglemode-0.89.1.tar.bz2) = 9a996b0309b7697d71b0350d1c74184bb979cdc079a2744870818abefb38fcd5
+SIZE (eaglemode-0.89.1.tar.bz2) = 5063741