aboutsummaryrefslogtreecommitdiffstats
path: root/x11/ebuttons
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-03-12 05:18:06 +0800
committergahr <gahr@FreeBSD.org>2008-03-12 05:18:06 +0800
commitf80cf9469b8fe9be79b1dba20d9a65fe6448d5cf (patch)
tree65a981d4b7d01b1247d3397c3a2dbcb8c190fd25 /x11/ebuttons
parent7843035eea9d002a1991cf57b8c8c617c6f55b1f (diff)
downloadfreebsd-ports-gnome-f80cf9469b8fe9be79b1dba20d9a65fe6448d5cf.tar.gz
freebsd-ports-gnome-f80cf9469b8fe9be79b1dba20d9a65fe6448d5cf.tar.zst
freebsd-ports-gnome-f80cf9469b8fe9be79b1dba20d9a65fe6448d5cf.zip
- Fix build with new libepplet2
- Remove dead mirror - Remove useless USE_PREFIX variable - Adopt maintainship Reported by: pointyhat (via erwin) Approved by: miwi (mentor)
Diffstat (limited to 'x11/ebuttons')
-rw-r--r--x11/ebuttons/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/x11/ebuttons/Makefile b/x11/ebuttons/Makefile
index ec7be06191eb..000d7fd6915e 100644
--- a/x11/ebuttons/Makefile
+++ b/x11/ebuttons/Makefile
@@ -7,24 +7,25 @@
PORTNAME= E-buttons
PORTVERSION= 0.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
-MASTER_SITES= http://freebsd.unixfreunde.de/sources/ \
- http://mirror2.unixfreunde.de/
+MASTER_SITES= http://freebsd.unixfreunde.de/sources/
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A simple epplet that contains several buttons used to launch programs
-LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/epplets
+LIB_DEPENDS= epplet.2:${PORTSDIR}/x11-wm/epplets \
+ Imlib2.4:${PORTSDIR}/graphics/imlib2
PLIST_FILES= bin/E-Buttons.epplet
WRKSRC= ${WRKDIR}/E-buttons
-USE_X_PREFIX= yes
+USE_GL= gl
+
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lepplet -lGL ${PTHREAD_LIBS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lepplet -lGL -lImlib2 ${PTHREAD_LIBS}
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o E-Buttons.epplet \