aboutsummaryrefslogtreecommitdiffstats
path: root/x11/fbdesk
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-17 19:04:07 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-17 19:04:07 +0800
commit0e91ba7388e63f2226b31792d511e6bdf1633304 (patch)
treec9c099a2ea6ac8c7802c3578589b25e5d5ac1c74 /x11/fbdesk
parenta74ae4ea011f99326009b13c0255455a206ab409 (diff)
downloadfreebsd-ports-gnome-0e91ba7388e63f2226b31792d511e6bdf1633304.tar.gz
freebsd-ports-gnome-0e91ba7388e63f2226b31792d511e6bdf1633304.tar.zst
freebsd-ports-gnome-0e91ba7388e63f2226b31792d511e6bdf1633304.zip
- Switch to options helpers
- Make imlib2 support non-optional, port doesn't build with it disabled
Diffstat (limited to 'x11/fbdesk')
-rw-r--r--x11/fbdesk/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index bf8b4a57f76c..e0a3b7fa4285 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -13,10 +13,8 @@ COMMENT= Fluxbox utility to create and manage icons on the desktop
LICENSE= MIT
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-
-OPTIONS_DEFINE= IMLIB2 DOCS
-OPTIONS_DEFAULT= IMLIB2
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
USE_XORG= xext xft xpm xrender
USES= pkgconfig
@@ -25,18 +23,10 @@ GNU_CONFIGURE= yes
PORTDOCS= ChangeLog INSTALL README
PLIST_FILES= bin/fbdesk
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMLIB2}
-LIB_DEPENDS+= libImlib2.so:${PORTSDIR}/graphics/imlib2
-.else
-CONFIGURE_ARGS+= --disable-imlib2
-.endif
+OPTIONS_DEFINE= DOCS
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>