aboutsummaryrefslogtreecommitdiffstats
path: root/x11/florence/Makefile
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-21 04:29:15 +0800
committerwg <wg@FreeBSD.org>2013-06-21 04:29:15 +0800
commit47d5b850dbd76237b93a86de6f490af833686fd8 (patch)
tree537465405cfd784d496af9f9955f43b39d8e3980 /x11/florence/Makefile
parente54c53f7f80082121b468564d05d39f7aa4345fe (diff)
downloadfreebsd-ports-gnome-47d5b850dbd76237b93a86de6f490af833686fd8.tar.gz
freebsd-ports-gnome-47d5b850dbd76237b93a86de6f490af833686fd8.tar.zst
freebsd-ports-gnome-47d5b850dbd76237b93a86de6f490af833686fd8.zip
x11/florence: update to 0.6.0
- Update to 0.6.0 - Add LICENSE (GPLv2 GFDL) - New world order USES: pathfix, desktop-file-utils - Add DOCS, man and NLS - Better pkg-descr - Pass maintainership to submitter Changes: http://sourceforge.net/p/florence/news/2012/10/florence-060-released/ PR: ports/179734 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'x11/florence/Makefile')
-rw-r--r--x11/florence/Makefile62
1 files changed, 44 insertions, 18 deletions
diff --git a/x11/florence/Makefile b/x11/florence/Makefile
index 7b86a874c49e..ff126c099af7 100644
--- a/x11/florence/Makefile
+++ b/x11/florence/Makefile
@@ -1,34 +1,60 @@
-# New ports collection makefile for: Florence
-# Date created: 2011/07/26
-# Whom: Kris Moore <kmoore@freebsd.org>
-#
+# Created by: Kris Moore <kmoore@freebsd.org>
# $FreeBSD$
-#
PORTNAME= florence
-PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTVERSION= 0.6.0
CATEGORIES= x11
MASTER_SITES= SF/florence/florence/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Florence OnScreen Keyboard
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Extensible scalable virtual keyboard
-LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
- cspi.10:${PORTSDIR}/accessibility/at-spi
+LICENSE= GPLv2 GFDL
+LICENSE_COMB= dual
-USE_XORG= xtst
-USE_GNOME= gtk20 intlhack gnomedocutils gconf2 librsvg2 gnomepanel
+LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
+BUILD_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at-spi2-core
USE_BZIP2= yes
-USES= gettext iconv
-USE_GMAKE= yes
+USES= desktop-file-utils gettext iconv pathfix
+USE_XORG= xtst xext
+USE_GNOME= gtk30 cairo intlhack gnomedocutils librsvg2
+USE_GSTREAMER= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--prefix=${LOCALBASE}
+USE_GMAKE= yes
USE_LDCONFIG= yes
INSTALLS_OMF= yes
-GCONF_SCHEMAS= florence.schemas
+GLIB_SCHEMAS= org.florence.gschema.xml
+
+MAN1= ${PORTNAME}.1 ${PORTNAME}_applet.1
+
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^Categories=.*|Categories=Application;Accessibility;System;|' \
+ ${WRKSRC}/data/florence.desktop.in.in
+
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|^ALL_LINGUAS.*|ALL_LINGUAS =|' \
+ ${WRKSRC}/po/Makefile.in.in
+.endif
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
.include <bsd.port.mk>