aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gdm
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-05-17 21:49:05 +0800
committermarcus <marcus@FreeBSD.org>2006-05-17 21:49:05 +0800
commitcb219d17d14ca5c49ef767ba11729445ce6968fe (patch)
treef040abc2fab5ff173cdde695f158aeb8d8f474e9 /x11/gdm
parenta70650423fffbd89754963f42dfdfdb5d02114be (diff)
downloadfreebsd-ports-gnome-cb219d17d14ca5c49ef767ba11729445ce6968fe.tar.gz
freebsd-ports-gnome-cb219d17d14ca5c49ef767ba11729445ce6968fe.tar.zst
freebsd-ports-gnome-cb219d17d14ca5c49ef767ba11729445ce6968fe.zip
Don't chgrp the /var/gdm directory to gdm during the instal phase since the
gdm user may not exist on the system yet. Instead, let the pkg-install script do this after verifying the gdm user and group exists. Reported by: pointyhat via kris
Diffstat (limited to 'x11/gdm')
-rw-r--r--x11/gdm/files/patch-config_Makefile.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/x11/gdm/files/patch-config_Makefile.in b/x11/gdm/files/patch-config_Makefile.in
index 7c844f55cefd..f04be74b41b0 100644
--- a/x11/gdm/files/patch-config_Makefile.in
+++ b/x11/gdm/files/patch-config_Makefile.in
@@ -1,6 +1,6 @@
---- config/Makefile.in.orig Fri May 12 15:37:48 2006
-+++ config/Makefile.in Fri May 12 15:38:05 2006
-@@ -682,7 +682,7 @@ install-data-hook: gdm.conf gdm.conf-cus
+--- config/Makefile.in.orig Wed May 17 13:47:25 2006
++++ config/Makefile.in Wed May 17 13:47:50 2006
+@@ -682,13 +682,13 @@ install-data-hook: gdm.conf gdm.conf-cus
if test '!' -d $(DESTDIR)$(logdir); then \
$(mkinstalldirs) $(DESTDIR)$(logdir); \
chmod 755 $(DESTDIR)$(logdir); \
@@ -9,3 +9,10 @@
fi
if test '!' -d $(DESTDIR)$(authdir); then \
+ $(mkinstalldirs) $(DESTDIR)$(authdir); \
+ chmod 1770 $(DESTDIR)$(authdir); \
+- chown root:gdm $(DESTDIR)$(authdir); \
++ chown root:wheel $(DESTDIR)$(authdir); \
+ fi
+
+ system=`uname`; \