aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-applets
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-03 04:45:14 +0800
committermarcus <marcus@FreeBSD.org>2004-01-03 04:45:14 +0800
commit07ddb57aa2843a29cc334350c7abde6fb3e28d0e (patch)
tree18d49cf60e19debcd095a76ae35b8f3f6e77e5f3 /x11/gnome-applets
parent343ae7da6142d29078e339a8bfefcede99a031bf (diff)
downloadfreebsd-ports-gnome-07ddb57aa2843a29cc334350c7abde6fb3e28d0e.tar.gz
freebsd-ports-gnome-07ddb57aa2843a29cc334350c7abde6fb3e28d0e.tar.zst
freebsd-ports-gnome-07ddb57aa2843a29cc334350c7abde6fb3e28d0e.zip
Add support for ath wireless cards.
Submitted by: Jung-uk Kim <jkim@niksun.com>
Diffstat (limited to 'x11/gnome-applets')
-rw-r--r--x11/gnome-applets/Makefile2
-rw-r--r--x11/gnome-applets/files/patch-wireless_wireless-applet.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 88f9750d2929..1aab246ea219 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomeapplets2
PORTVERSION= 2.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-applets/2.4
diff --git a/x11/gnome-applets/files/patch-wireless_wireless-applet.c b/x11/gnome-applets/files/patch-wireless_wireless-applet.c
index 7bf4eceb0d0f..a1da56f696a8 100644
--- a/x11/gnome-applets/files/patch-wireless_wireless-applet.c
+++ b/x11/gnome-applets/files/patch-wireless_wireless-applet.c
@@ -242,7 +242,7 @@
+ }
+ }
+ else
-+ if (g_strncasecmp(device, "wi", 2)==0) {
++ if (g_strncasecmp(device, "wi", 2)==0 || g_strncasecmp(device, "ath", 3)==0) {
+ applet->devices = g_list_prepend (applet->devices, g_strdup (device));
+ if (g_strcasecmp(applet->device, device)==0) {
+ get_wi_data(applet, device, &level);