aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-applets
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-01-17 05:49:41 +0800
committeradamw <adamw@FreeBSD.org>2004-01-17 05:49:41 +0800
commitc096d1eb212fbcc8bd47e1ecac3a828bbc05a35b (patch)
tree9283d546eba830477764a600af9e1f676cc14b03 /x11/gnome-applets
parent2808d15f692bf1598b7e8c91c6eb629a72549db3 (diff)
downloadfreebsd-ports-gnome-c096d1eb212fbcc8bd47e1ecac3a828bbc05a35b.tar.gz
freebsd-ports-gnome-c096d1eb212fbcc8bd47e1ecac3a828bbc05a35b.tar.zst
freebsd-ports-gnome-c096d1eb212fbcc8bd47e1ecac3a828bbc05a35b.zip
Update to 2.4.2.
Diffstat (limited to 'x11/gnome-applets')
-rw-r--r--x11/gnome-applets/Makefile7
-rw-r--r--x11/gnome-applets/distinfo2
-rw-r--r--x11/gnome-applets/files/patch-charpick_charpick.c11
-rw-r--r--x11/gnome-applets/files/patch-wireless_wireless-applet.c43
-rw-r--r--x11/gnome-applets/pkg-plist6
5 files changed, 29 insertions, 40 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 1aab246ea219..15fa4b17fedc 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnomeapplets2
-PORTVERSION= 2.4.1
-PORTREVISION= 3
+PORTVERSION= 2.4.2
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-applets/2.4
@@ -31,9 +30,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-PLIST_SUB= BATTERY="@comment "
+PLIST_SUB= BATTERY="@comment "
.else
-PLIST_SUB= BATTERY=""
+PLIST_SUB= BATTERY=""
.endif
.include <bsd.port.post.mk>
diff --git a/x11/gnome-applets/distinfo b/x11/gnome-applets/distinfo
index e12450bdce88..1f6f24b55d93 100644
--- a/x11/gnome-applets/distinfo
+++ b/x11/gnome-applets/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gnome-applets-2.4.1.tar.bz2) = bf018f1692ab305954123d8123ef45d1
+MD5 (gnome2/gnome-applets-2.4.2.tar.bz2) = 3a59c7f5b452e4f9675dfce44a2b3433
diff --git a/x11/gnome-applets/files/patch-charpick_charpick.c b/x11/gnome-applets/files/patch-charpick_charpick.c
deleted file mode 100644
index 7d0ee91eb476..000000000000
--- a/x11/gnome-applets/files/patch-charpick_charpick.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- charpick/charpick.c.orig Wed Sep 10 13:33:00 2003
-+++ charpick/charpick.c Wed Sep 10 13:33:19 2003
-@@ -3,7 +3,7 @@
- */
-
- #include <config.h>
--#ifndef sun
-+#if !defined(sun) && !defined(__FreeBSD__)
- #include <tgmath.h>
- #endif
- #include <panel-applet.h>
diff --git a/x11/gnome-applets/files/patch-wireless_wireless-applet.c b/x11/gnome-applets/files/patch-wireless_wireless-applet.c
index a1da56f696a8..1f1af0974a9d 100644
--- a/x11/gnome-applets/files/patch-wireless_wireless-applet.c
+++ b/x11/gnome-applets/files/patch-wireless_wireless-applet.c
@@ -1,5 +1,5 @@
---- wireless/wireless-applet.c.orig Mon Sep 22 19:06:44 2003
-+++ wireless/wireless-applet.c Tue Sep 23 00:17:03 2003
+--- wireless/wireless-applet.c.orig Mon Oct 27 15:52:14 2003
++++ wireless/wireless-applet.c Fri Jan 16 16:47:14 2004
@@ -30,6 +30,15 @@
#include <math.h>
#include <dirent.h>
@@ -72,7 +72,7 @@
wireless_applet_draw (applet, percent);
}
-@@ -235,22 +260,179 @@
+@@ -235,22 +260,180 @@
}
}
@@ -116,7 +116,7 @@
+static void
+get_wi_data (WirelessApplet *applet, char *device, long int *level)
+{
-+ struct wi_req wreq;
++ struct wi_req wreq;
+ long int signal_strength;
+
+ bzero((char *)&wreq, sizeof(wreq));
@@ -156,9 +156,9 @@
+
+ if (ioctl(s, SIOCGAIRONET, &ifr) == -1) {
+ gtk_tooltips_set_tip (applet->tips,
-+ GTK_WIDGET (applet),
-+ "ioctl Error",
-+ NULL);
++ GTK_WIDGET (applet),
++ "ioctl Error",
++ NULL);
+ return 0;
+ }
+
@@ -169,7 +169,7 @@
+static void
+get_an_data (WirelessApplet *applet, char *device, long int *level)
+{
-+ struct an_req areq;
++ struct an_req areq;
+ struct an_ltv_status *sts;
+#ifdef AN_RID_RSSI_MAP
+ struct an_ltv_rssi_map an_rssimap;
@@ -192,13 +192,13 @@
+#ifdef AN_RID_RSSI_MAP
+ if (rssimap_valid)
+ signal_strength = (long int)(an_rssimap.an_entries[
-+ sts->an_normalized_strength].an_rss_pct);
++ sts->an_normalized_strength].an_rss_pct);
+ else
+ signal_strength = (long int)(sts->an_normalized_strength);
+#else
+ signal_strength = (long int)(sts->an_normalized_rssi);
+#endif
-+
++
+ memcpy(level, &signal_strength, sizeof(level));
+}
+#endif
@@ -230,14 +230,14 @@
/* Here we begin to suck... */
do {
+#ifdef __FreeBSD__
-+ if (ifs == NULL || ifs->if_name == NULL) {
++ if (ifs == NULL || ifs->if_name == NULL) {
+ break;
+ }
-+ strlcpy(device, ifs->if_name, 6);
++ strlcpy(device, ifs->if_name, 6);
+ if (g_strncasecmp(device, "an", 2)==0) {
+ applet->devices = g_list_prepend (applet->devices, g_strdup (device));
+ if (g_strcasecmp(applet->device, device)==0) {
-+ get_an_data(applet, device, &level);
++ get_an_data(applet, device, &level);
+ wireless_applet_update_state (applet, device, 0, level, 0);
+ }
+ }
@@ -245,16 +245,17 @@
+ if (g_strncasecmp(device, "wi", 2)==0 || g_strncasecmp(device, "ath", 3)==0) {
+ applet->devices = g_list_prepend (applet->devices, g_strdup (device));
+ if (g_strcasecmp(applet->device, device)==0) {
-+ get_wi_data(applet, device, &level);
++ get_wi_data(applet, device, &level);
+ wireless_applet_update_state (applet, device, 0, level, 0);
+ }
+ }
+ ifs++;
+#else
++
char *ptr;
fgets (line, 256, applet->file);
-@@ -283,6 +465,7 @@
+@@ -283,6 +466,7 @@
wireless_applet_update_state (applet, device, link, level, noise);
}
}
@@ -262,7 +263,7 @@
} while (1);
if (g_list_length (applet->devices)==1) {
-@@ -294,17 +477,23 @@
+@@ -294,17 +478,23 @@
}
/* rewind the /proc/net/wireless file */
@@ -286,7 +287,7 @@
wireless_applet_read_device_state (applet);
-@@ -351,6 +540,7 @@
+@@ -351,6 +541,7 @@
static void
start_file_read (WirelessApplet *applet)
{
@@ -294,7 +295,7 @@
applet->file = fopen ("/proc/net/wireless", "rt");
if (applet->file == NULL) {
gtk_tooltips_set_tip (applet->tips,
-@@ -359,6 +549,7 @@
+@@ -359,6 +550,7 @@
NULL);
show_error_dialog (_("There doesn't seem to be any wireless devices configured on your system.\nPlease verify your configuration if you think this is incorrect."));
}
@@ -302,7 +303,7 @@
}
static void
-@@ -641,8 +832,10 @@
+@@ -646,8 +838,10 @@
applet->prefs = NULL;
}
@@ -310,6 +311,6 @@
if (applet->file)
fclose (applet->file);
+#endif
+ if (applet->tips)
+ g_object_unref (applet->tips);
}
-
- static void
diff --git a/x11/gnome-applets/pkg-plist b/x11/gnome-applets/pkg-plist
index 386e02b72507..f673803f1995 100644
--- a/x11/gnome-applets/pkg-plist
+++ b/x11/gnome-applets/pkg-plist
@@ -858,6 +858,8 @@ share/gnome/omf/gnome-applets/gweather-es.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather-es.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-applets/gweather-fr.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather-fr.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gnome-applets/gweather-it.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather-it.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-applets/gweather-ja.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather-ja.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-applets/gweather-ko.omf
@@ -868,8 +870,6 @@ share/gnome/omf/gnome-applets/gweather-zh_CN.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather-zh_CN.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-applets/gweather-zh_TW.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather-zh_TW.omf 2>/dev/null || /usr/bin/true
-share/gnome/omf/gnome-applets/gweather_applet-it.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/gweather_applet-it.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-applets/mailcheck-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-applets/mailcheck-C.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-applets/mailcheck-de.omf
@@ -1519,12 +1519,12 @@ share/locale/zh_TW/LC_MESSAGES/gnome-applets-2.0.mo
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-de.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-es.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-fr.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-it.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-ja.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-ko.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-sv.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-zh_CN.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather-zh_TW.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/gweather_applet-it.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/mailcheck-C.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/mailcheck-de.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnome-applets/mailcheck-es.omf 2>/dev/null || /usr/bin/true