aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-screensaver
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
commit4f3e737e3339df65a7737d86948a5c8dacedae60 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /x11/gnome-screensaver
parent38d22f91997e71dd03618ec2d16c51e19e000cd9 (diff)
downloadfreebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.gz
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.zst
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Diffstat (limited to 'x11/gnome-screensaver')
-rw-r--r--x11/gnome-screensaver/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index 65dd6f4ef497..d7d155cc4ce4 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnome-screensaver
-# Date created: 09 June 2005
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.124 2011/04/09 16:54:20 mezz Exp $
-#
+# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.125 2012/09/03 16:28:29 mezz Exp $
PORTNAME= gnome-screensaver
PORTVERSION= 2.30.2
@@ -16,7 +12,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME screen saver and locker
-LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= xscreensaver-gl-helper:${PORTSDIR}/x11/xscreensaver-gnome-hacks
CONFLICTS= gnome-screensaver-3.[0-9]*
@@ -26,8 +22,8 @@ USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_XORG= xtst xxf86vm
-USE_GNOME= gnomeprefix gnomehack intlhack gnomemenus libgnomekbd \
- gnomedesktop
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack gnomemenus libgnomekbd gnomedesktop
CONFIGURE_ARGS= --with-gdm-config=${LOCALBASE}/etc/gdm/custom.conf \
--with-xscreensaverdir=${XSCREENSAVER_DIR} \
--with-xscreensaverhackdir=${LOCALBASE}/bin/xscreensaver-hacks
@@ -46,12 +42,14 @@ SCREENSAVER_DIR= share/applications/screensavers
XSCREENSAVER_EXCLUDE= "(popsquares.xml)"
-OPTIONS= PAM "Pluggable Authentication Module support" on \
- KEYRING "Enable GnomeKeyring integration (needs PAM)" on
+OPTIONS_DEFINE= PAM KEYRING
+OPTIONS_DEFAULT=PAM KEYRING
+PAM_DESC= Pluggable Authentication Module support
+KEYRING_DESC= GnomeKeyring integration (needs PAM)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
RUN_DEPENDS+= pam_helper:${PORTSDIR}/security/pam_helper
CONFIGURE_ARGS+= --enable-authentication-scheme=helper \
--with-passwd-helper=${LOCALBASE}/bin/pam_helper
@@ -61,7 +59,7 @@ CONFIGURE_ARGS+= --disable-pam
PLIST_SUB+= PAM="@comment "
.endif
-.if defined(WITH_KEYRING) && defined(WITH_PAM)
+.if ${PORT_OPTIONS:MKEYRING} && ${PORT_OPTIONS:MPAM}
SUB_LIST+= PAM_KEYRING=
RUN_DEPENDS+= ${LOCALBASE}/lib/pam_gnome_keyring.so:${PORTSDIR}/security/gnome-keyring
.else
@@ -69,12 +67,12 @@ SUB_LIST+= PAM_KEYRING=\#
.endif
pre-everything::
-.if defined(WITHOUT_PAM) && defined(WITH_KEYRING)
+.if !${PORT_OPTIONS:MPAM} && ${PORT_OPTIONS:MKEYRING}
@${ECHO_MSG} "Keyring integration is disabled because it needs PAM."
.endif
post-patch:
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
@${REINPLACE_CMD} -e 's|/etc/pam.d|${PREFIX}/etc/pam.d|g' \
${WRKSRC}/src/gs-auth-pam.c
.endif
@@ -95,8 +93,8 @@ post-install:
${FIND} -s ${XSCREENSAVER_DIR} -maxdepth 1 -type f -name "*.xml" | \
${GREP} -Ev ${XSCREENSAVER_EXCLUDE} | \
${XARGS} ${WRKSRC}/data/migrate-xscreensaver-config.sh
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
${INSTALL_DATA} ${WRKDIR}/gnome-screensaver.pam ${PREFIX}/etc/pam.d/gnome-screensaver
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>