aboutsummaryrefslogtreecommitdiffstats
path: root/x11/hs-X11
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2019-05-10 01:31:06 +0800
committerGleb Popov <arrowd@FreeBSD.org>2019-05-10 01:31:06 +0800
commit533efced70cb2a11eaf289df402520178b615873 (patch)
treee898f50a11d401117e553c1de8630bfb0463ff0b /x11/hs-X11
parent9095f2410badb650a4f4f5907eaf1fc0bcfaaa0f (diff)
downloadfreebsd-ports-gnome-533efced70cb2a11eaf289df402520178b615873.tar.gz
freebsd-ports-gnome-533efced70cb2a11eaf289df402520178b615873.tar.zst
freebsd-ports-gnome-533efced70cb2a11eaf289df402520178b615873.zip
Restore some Haskell libraries. These are still required to build x11/hs-xmonad.
Reported by: antoine Approved by: tcberner (mentor)
Diffstat (limited to 'x11/hs-X11')
-rw-r--r--x11/hs-X11/Makefile29
-rw-r--r--x11/hs-X11/distinfo3
-rw-r--r--x11/hs-X11/pkg-descr4
3 files changed, 36 insertions, 0 deletions
diff --git a/x11/hs-X11/Makefile b/x11/hs-X11/Makefile
new file mode 100644
index 000000000000..8fe0e12ee0b0
--- /dev/null
+++ b/x11/hs-X11/Makefile
@@ -0,0 +1,29 @@
+# Created by: Volker Stolz <vs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= X11
+PORTVERSION= 1.8
+PORTREVISION= 5
+CATEGORIES= x11 haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to the X11 graphics library
+
+LICENSE= BSD3CLAUSE
+
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
+USE_CABAL= data-default
+USE_XORG= x11 xrandr xext
+
+FLAGS_DEFINE= XINERAMA
+FLAGS_DEFAULT= XINERAMA
+
+XINERAMA_DESC= Build with Xinerama support
+XINERAMA_FLAG_XORG= xinerama
+XINERAMA_FLAG_CONFIGURE_ON= --configure-option="--with-xinerama"
+XINERAMA_FLAG_CONFIGURE_OFF= --configure-option="--without-xinerama"
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/x11/hs-X11/distinfo b/x11/hs-X11/distinfo
new file mode 100644
index 000000000000..72f1c887d06d
--- /dev/null
+++ b/x11/hs-X11/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486838578
+SHA256 (cabal/X11-1.8.tar.gz) = 541b166aab1e05a92dc8f42a511d827e7aad373af12ae283b9df9982ccc09d8e
+SIZE (cabal/X11-1.8.tar.gz) = 191331
diff --git a/x11/hs-X11/pkg-descr b/x11/hs-X11/pkg-descr
new file mode 100644
index 000000000000..3f1b006d7d42
--- /dev/null
+++ b/x11/hs-X11/pkg-descr
@@ -0,0 +1,4 @@
+A Haskell binding to the X11 library. The binding is a direct
+translation of C binding.
+
+WWW: https://github.com/haskell-pkg-janitors/X11