aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-runtime
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-02 21:10:50 +0800
committerlofi <lofi@FreeBSD.org>2004-05-02 21:10:50 +0800
commit34d09d4230fe597fef45470f2b389a094a49543a (patch)
treead921fd993202f44718ac69619c98f2228b51c29 /x11/kde4-runtime
parent34a8357c85d8011656a30af71f2b9a87443102c7 (diff)
downloadfreebsd-ports-gnome-34d09d4230fe597fef45470f2b389a094a49543a.tar.gz
freebsd-ports-gnome-34d09d4230fe597fef45470f2b389a094a49543a.tar.zst
freebsd-ports-gnome-34d09d4230fe597fef45470f2b389a094a49543a.zip
Process the pkg-message template earlier than post-install so
package users will actually get to see it the right way. PR: ports/66123 Reported by: obrien
Diffstat (limited to 'x11/kde4-runtime')
-rw-r--r--x11/kde4-runtime/Makefile10
-rw-r--r--x11/kde4-runtime/files/pkg-message (renamed from x11/kde4-runtime/pkg-message)0
2 files changed, 7 insertions, 3 deletions
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kde4-runtime/pkg-message b/x11/kde4-runtime/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kde4-runtime/pkg-message
+++ b/x11/kde4-runtime/files/pkg-message