aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace/Makefile
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
commit18f8d6818a2205ed543432ae7b736e36bb0b1ab5 (patch)
treea38d8a80d7330fafe33e6504e265797c7db5c8ee /x11/kde4-workspace/Makefile
parent7e1a35526ca99e8f9cc466c562f4184911eb911c (diff)
downloadfreebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.gz
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.zst
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.zip
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Diffstat (limited to 'x11/kde4-workspace/Makefile')
-rw-r--r--x11/kde4-workspace/Makefile81
1 files changed, 62 insertions, 19 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 02f198187678..5e1f5ca92a55 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-PORTNAME= kdebase-workspace
+PORTNAME= kde-workspace
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE_kde} \
@@ -21,15 +21,26 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic applications for the KDE system
-LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz\
+LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
dbus-1.3:${PORTSDIR}/devel/dbus \
+ ck-connector.0:${PORTSDIR}/sysutils/consolekit \
pci.3:${PORTSDIR}/devel/libpci \
hal.1:${PORTSDIR}/sysutils/hal \
- xklavier.12:${PORTSDIR}/x11/libxklavier \
- gps.20:${PORTSDIR}/astro/gpsd \
qalculate.5:${PORTSDIR}/math/libqalculate \
- dmtx.0:${PORTSDIR}/graphics/libdmtx
+ prison.0:${PORTSDIR}/graphics/prison \
+ searchclient.0:${PORTSDIR}/deskutils/strigi \
+ soprano.4:${PORTSDIR}/textproc/soprano \
+ boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ dbusmenu-qt.2:${PORTSDIR}/devel/libdbusmenu-qt \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ ttf.4:${PORTSDIR}/print/freetype \
+ png.6:${PORTSDIR}/graphics/png \
+ jpeg.11:${PORTSDIR}/graphics/jpeg
+
+BUILD_DEPENDS= ${LOCALBASE}/share/ontology/core/rdf.ontology:${PORTSDIR}/x11-toolkits/shared-desktop-ontologies
+
RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
+ ${LOCALBASE}/share/ontology/core/rdf.ontology:${PORTSDIR}/x11-toolkits/shared-desktop-ontologies \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
xprop:${PORTSDIR}/x11/xprop \
xsetroot:${PORTSDIR}/x11/xsetroot \
@@ -40,40 +51,68 @@ RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
setxkbmap:${PORTSDIR}/x11/setxkbmap \
${KDE4_PREFIX}/bin/ksysguardd:${PORTSDIR}/sysutils/ksysguardd \
${KDE4_PREFIX}/lib/kde4/libexec/polkit-kde-authentication-agent-1:${PORTSDIR}/sysutils/polkit-kde \
- ${KDE4_PREFIX}/bin/nepomukcontroller:${PORTSDIR}/misc/nepomukcontroller
+ ${LOCALBASE}/etc/pam.d/kde:${PORTSDIR}/security/pam_kde
+
+CONFLICTS= kdeaccessibility-4.[0-6].* kdebase-workspace-4.[0-6].*
-SUB_FILES= kdm layout.js pkg-message
+SUB_FILES= kdm layout.js
USE_RC_SUBR= kdm4
-USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4 oxygen
-KDE4_BUILDENV= yes
-USE_GMAKE= yes
USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= assistant corelib dbus designer gui network opengl \
- script svg sql qt3support qtestlib xml webkit \
- qmake_build moc_build rcc_build uic_build \
- porting_build uic3_build phonon
-USE_XORG= xtst xscrnsaver
USE_GETTEXT= yes
+USE_GNOME= glib20
USE_ICONV= yes
+USE_KDE4= akonadi automoc4 kdehier kdelibs kdeprefix oxygen pimlibs
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= dbus declarative gui network opengl phonon \
+ qt3support qtestlib script sql webkit xml \
+ moc_build qmake_build rcc_build uic_build
+USE_XORG= kbproto x11 xau xcomposite xcursor xdamage xdmcp xfixes \
+ xft xi xinerama xkbfile xrandr xrender xres xscrnsaver xtst
+USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
+USERS= kdm
+GROUPS= kdm
+
MAN1= plasmaengineexplorer.1 plasmapkg.1 plasmoidviewer.1
+# PyKDE4, Xmms and Googlegadgets could be enabled.
CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
+ -DBUILD_python:BOOL=OFF \
+ -DBUILD_ruby:BOOL=OFF \
-DWITH_BlueZ:BOOL=OFF \
-DWITH_Sensors:BOOL=OFF \
-DWITH_NetworkManager:BOOL=OFF \
-DWITH_Xmms:BOOL=OFF \
-DWITH_Googlegadgets:BOOL=OFF \
-DWITH_PyKDE4:BOOL=OFF
-#PyKDE4, Xmms and Googlegadgets could be enabled,
-OPTIONS= PLASMA_PYTHON "Support for plasmoids written in Python" off \
+OPTIONS= GPS "Support for GPS geolocation dataengine" on \
+ PHONON_GSTREAMER "GStreamer backend for Phonon (recommended)" on \
+ PHONON_VLC "VLC backend for Phonon" off \
+ PLASMA_PYTHON "Support for plasmoids written in Python" off \
PLASMA_RUBY "Support for plasmoids written in Ruby" off
.include <bsd.port.options.mk>
+.if !defined(WITHOUT_GPS)
+LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
+CMAKE_ARGS+= -DWITH_libgps:BOOL=ON
+PLIST_SUB+= GPS=""
+.else
+CMAKE_ARGS+= -DWITH_libgps:BOOL=OFF
+PLIST_SUB+= GPS="@comment "
+.endif
+
+.if !defined(WITHOUT_PHONON_GSTREAMER)
+RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/plugins/phonon_backend/phonon_gstreamer.so:${PORTSDIR}/multimedia/phonon-gstreamer
+.endif
+
+.if defined(WITH_PHONON_VLC)
+RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/plugins/phonon_backend/phonon_vlc.so:${PORTSDIR}/multimedia/phonon-vlc
+.endif
+
.if defined(WITH_PLASMA_PYTHON)
RUN_DEPENDS+= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_python/plasma_importer.py:${PORTSDIR}/x11/plasma-scriptengine-python
.endif
@@ -82,6 +121,8 @@ RUN_DEPENDS+= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_python/plasma_import
RUN_DEPENDS+= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_ruby/applet.rb:${PORTSDIR}/x11/plasma-scriptengine-ruby
.endif
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
@@ -106,6 +147,8 @@ pre-configure:
${PATCH_WRKSRC}/ksysguard/example/CMakeLists.txt
${REINPLACE_CMD} -e 's|<qhash.h>|<QHash>|' \
${PATCH_WRKSRC}/kwin/effects/thumbnailaside/thumbnailaside.h
+ ${REINPLACE_CMD} -e '/PolicyKit/ d' \
+ ${PATCH_WRKSRC}/doc/CMakeLists.txt
post-install:
${LN} -sf ${PREFIX}/bin/startkde ${PREFIX}/bin/startkde4
@@ -120,4 +163,4 @@ post-install:
${COPYTREE_SHARE} . ${PREFIX}/share/wallpapers
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>