aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-10-19 23:57:27 +0800
committermakc <makc@FreeBSD.org>2014-10-19 23:57:27 +0800
commit25c68bc4526056d98d62f1efe29e6059f175ce69 (patch)
tree7d99a8b7b1226b2da14c7c6d04800d30a417873e /x11/kde4-workspace/Makefile
parent2cd94a0cdc2c275bb71369d565efbaccb4a48c1b (diff)
downloadfreebsd-ports-gnome-25c68bc4526056d98d62f1efe29e6059f175ce69.tar.gz
freebsd-ports-gnome-25c68bc4526056d98d62f1efe29e6059f175ce69.tar.zst
freebsd-ports-gnome-25c68bc4526056d98d62f1efe29e6059f175ce69.zip
KDE/FreeBSD team presents KDE SC 4.14.2 and KDE Workspace 4.11.13!
USE_KDE4=kdehier component has been deprecated, new components added: baloo - Baloo core libraries baloo-widgets - Baloo widgets library kfilemetadata - KDE library for extracting file metadata New ports: graphics/kqtquickcharts - QtQuick plugin to render interactive charts misc/artikulate - Pronunciation trainer for KDE (not usable currently, links to both GStreamer 1.x and 0.10.x via dependencies) sysutils/baloo[-widgets] - KDE framework for searching and managing user metadata sysutils/kfilemetadata - Library for extracting file metadata l10n ports: - Farsi (Persian) and Indonesian translations has been readded - Vietnamese didn't pass threshold for inclusion into release astro/kstars: - switch dependency from math/eigen2 to math/eigen3 - add PYKDE option for updating supernovae data deskutils/kdepim4: - update dependencies: add libkgapi and baloo, remove now needless clucene, link-grammar, strigi - add patch to fix build with gcc42 - update COMMENT and description for all KDE PIM ports devel/ruby-krossruby: - remove BROKEN, it builds with ruby 2.x now editors/kate: - add patch to disable memory-hungry build of the kate tests [1] graphics/okular: - add dependency on graphics/libkscreen math/cantor: - add optional dependency on lang/luajit for LuaJIT backend - fix gfortran detection [2] misc/kdehier4: - adapt to new pkg world. Now the purpose of kdehier4 only to link some stuff between KDE4_PREFIX and LOCALBASE. science/kalzium: - switch dependency from math/eigen2 to math/eigen3 - add dependence on science/chemical-mime-data x11-themes/kdeartwork4 - switch dependency from math/eigen2 to math/eigen3 among other changes: - drop deprecated USE_KDE4=kdehier - drop @dirrm from plist - clean up pkg-descr - convert to options helpers - other portlint fixes The area51 repository features commits by alonso, rakuco and myself. PR: 187150 [1] Reported by: pe.freethread@live.com Patch by: Tobias Berner <tcberner@gmail.com> PR: 180674 [2] Reported by: torsten.eichstaedt@web.de PR: 194316 Exp-run: antoine
Diffstat (limited to 'x11/kde4-workspace/Makefile')
-rw-r--r--x11/kde4-workspace/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 05bf11d29140..27b3c08df361 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${KDE4_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -43,8 +42,8 @@ RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
USE_GL= glu
USE_GNOME= glib20
-USE_KDE4= kactivities kdehier kdelibs kdeprefix oxygen pimlibs \
- akonadi automoc4 ontologies qimageblitz soprano strigi
+USE_KDE4= kactivities kdelibs kdeprefix nepomuk-core oxygen \
+ pimlibs akonadi automoc4 ontologies qimageblitz soprano strigi
USES= cmake:outsource compiler:c++11-lib gettext gmake iconv \
pkgconfig tar:xz
USE_QT4= corelib dbus declarative designer_build gui network \
@@ -54,7 +53,6 @@ USE_XORG= kbproto x11 xau xcomposite xcursor xdamage xdmcp xfixes \
xft xi xinerama xkbfile xrandr xrender xres xscrnsaver xtst
USE_LDCONFIG= yes
-# Xmms and Googlegadgets could be enabled.
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DBUILD_python:BOOL=OFF \
-DBUILD_ruby:BOOL=OFF \