aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 22:15:03 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 22:15:03 +0800
commitd25e7fc771070e3ec184f069986cc24d78e3b572 (patch)
treec4ea42245d0b053c1a31462b408d6990c18047e0 /x11/kde4-workspace
parent4fc1ebe6fd71add26a2a950884c9af3e4f24a915 (diff)
downloadfreebsd-ports-gnome-d25e7fc771070e3ec184f069986cc24d78e3b572.tar.gz
freebsd-ports-gnome-d25e7fc771070e3ec184f069986cc24d78e3b572.tar.zst
freebsd-ports-gnome-d25e7fc771070e3ec184f069986cc24d78e3b572.zip
Convert LIB_DEPENDS for ports depending on boost
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 808a2df6c2d1..13926795aaf8 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -11,20 +11,20 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Plasma Desktop
-LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
- ck-connector:${PORTSDIR}/sysutils/consolekit \
- pci:${PORTSDIR}/devel/libpci \
- hal:${PORTSDIR}/sysutils/hal \
- qalculate:${PORTSDIR}/math/libqalculate \
- prison:${PORTSDIR}/graphics/prison \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- dbusmenu-qt:${PORTSDIR}/devel/libdbusmenu-qt \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- xcb-render-util:${PORTSDIR}/x11/xcb-util-renderutil \
- xcb-image:${PORTSDIR}/x11/xcb-util-image
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libck-connector.so:${PORTSDIR}/sysutils/consolekit \
+ libpci.so:${PORTSDIR}/devel/libpci \
+ libhal.so:${PORTSDIR}/sysutils/hal \
+ libqalculate.so:${PORTSDIR}/math/libqalculate \
+ libprison.so:${PORTSDIR}/graphics/prison \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libdbusmenu-qt.so:${PORTSDIR}/devel/libdbusmenu-qt \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libxcb-render-util.so:${PORTSDIR}/x11/xcb-util-renderutil \
+ libxcb-image.so:${PORTSDIR}/x11/xcb-util-image
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \