aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdebase4-runtime/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-08-31 19:27:34 +0800
committerolgeni <olgeni@FreeBSD.org>2001-08-31 19:27:34 +0800
commitc2fdddb95f858ed0f4d91e5e8f9325b7b61f961b (patch)
tree3dc947604ffd930c529b68c7f93c4ab625cd5e8e /x11/kdebase4-runtime/Makefile
parenta9879c7a6be96c374bf8908227ad34976d7430b4 (diff)
downloadfreebsd-ports-gnome-c2fdddb95f858ed0f4d91e5e8f9325b7b61f961b.tar.gz
freebsd-ports-gnome-c2fdddb95f858ed0f4d91e5e8f9325b7b61f961b.tar.zst
freebsd-ports-gnome-c2fdddb95f858ed0f4d91e5e8f9325b7b61f961b.zip
Support the Motif-dependent files in pkg-plist, add some missing @dirrm
entries, and move the @exec/@unexec entries to make the other @dirrms actually work.
Diffstat (limited to 'x11/kdebase4-runtime/Makefile')
-rw-r--r--x11/kdebase4-runtime/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index ae09c507e98e..2a4dfc2629ef 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -30,6 +30,26 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--disable-closure
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if exists(${X11BASE}/include/Xm/Xm.h)
+WITH_MOTIF= yes
+.endif
+
+.if defined(WITH_MOTIF) && ${WITH_MOTIF} == yes
+USE_MOTIF= yes
+PLIST_SUB+= MOTIF=""
+.else
+PLIST_SUB+= MOTIF="@comment "
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with Motif support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG}
+.endif
+
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
@${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
@@ -43,4 +63,4 @@ pre-configure:
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>