aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdebase4-workspace
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-07-18 19:16:37 +0800
committeralane <alane@FreeBSD.org>2002-07-18 19:16:37 +0800
commitb18c0a83d8ac65bc6743e52169749740a352b58a (patch)
tree14d2d8a7874157e4ffd1e2fa91fa0956be65d96d /x11/kdebase4-workspace
parentbe93d19ab95ff13b19a5893476ee3a7f9d367cb2 (diff)
downloadfreebsd-ports-gnome-b18c0a83d8ac65bc6743e52169749740a352b58a.tar.gz
freebsd-ports-gnome-b18c0a83d8ac65bc6743e52169749740a352b58a.tar.zst
freebsd-ports-gnome-b18c0a83d8ac65bc6743e52169749740a352b58a.zip
Fixed obnoxious bug where a new ~/Desktop dir would be created with read-only
files (including a RO .directory), which prevented certain changes, like moving icons around, from persisting to next session. <Aaarrgh> They used system("cp file1 file2") to create the new dirs. </Aaarrgh> PORTREVISION was bumped on this one, since it is a significant fix, and it does affect installation of files (in the user's $HOME). PR: 39980
Diffstat (limited to 'x11/kdebase4-workspace')
-rw-r--r--x11/kdebase4-workspace/Makefile1
-rw-r--r--x11/kdebase4-workspace/files/patch-kdesktop-init.cc22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 90854ebb4d7b..ade5079ca105 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdebase4-workspace/files/patch-kdesktop-init.cc b/x11/kdebase4-workspace/files/patch-kdesktop-init.cc
new file mode 100644
index 000000000000..f7fe48544866
--- /dev/null
+++ b/x11/kdebase4-workspace/files/patch-kdesktop-init.cc
@@ -0,0 +1,22 @@
+--- kdesktop/init.cc.orig Fri Oct 12 15:11:13 2001
++++ kdesktop/init.cc Thu Jul 18 06:48:59 2002
+@@ -80,6 +80,9 @@
+ QFile::encodeName(locate("data", QString("kdesktop/") + fileName)).data(),
+ QFile::encodeName(dir).data() );
+ system( cmd );
++ cmd.sprintf( "chmod 644 %s/.directory",
++ QFile::encodeName(dir).data() );
++ system( cmd );
+ }
+ }
+
+@@ -106,6 +109,9 @@
+ cmd += "' '";
+ cmd += QFile::encodeName(desktopPath + desk.readName());
+ cmd += "'";
++ system( cmd );
++ cmd.sprintf("chmod 644 '%s'",
++ QFile::encodeName(desktopPath + desk.readName()).data());
+ system( cmd );
+ }
+ }