aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs4/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-08-15 20:43:08 +0800
committerwill <will@FreeBSD.org>2001-08-15 20:43:08 +0800
commit23147495997b85ea546398f34cf419d087c7513b (patch)
treecb3884a41c6faa05677af2e14338aa3202a61883 /x11/kdelibs4/Makefile
parent5449e6cf16ffba429ee30a6243c85e99c388fd4d (diff)
downloadfreebsd-ports-gnome-23147495997b85ea546398f34cf419d087c7513b.tar.gz
freebsd-ports-gnome-23147495997b85ea546398f34cf419d087c7513b.tar.zst
freebsd-ports-gnome-23147495997b85ea546398f34cf419d087c7513b.zip
Update to KDE 2.2:
* All patches except sysutils/kdeadmin/files/patch-rpmMessages.c: - Either obsoleted or merged into KDE. * All pkg-plists: - Huge diffs are due to mass conversion from static HTML pages to XML/XSL versions. * audio/kdemultimedia2: - aRts + Noatun, etc. now work and play MP3s et al properly, using the mpg123 aRtsplugin. Remove mpeglib[,_artsplug] from compile. * converters/kdesupport2: - Obsolete. No longer used in this version of KDE. * deskutils/kdepim: - Use autoconf and account for brokenness in the configure script by replacing invocations of INSTALL under libical with the proper incantations. - Per David O'Brien's request, move libimap to libkimap; this was performed by Rik Hemsley <rikkus@kde.org>. * devel/kdesdk: - New module with some helpful tools. One in particular that seems demanded is ``kbabel'', which, as I've been told, is a translator's wet dream. - Workaround dumb problem in kbabel's libgettext (which I could not figure out how to remove) by replacing its error() with errc(). KBabel seems to run fine with this patch. * devel/kdevelop: - Fix lame check for libkdeui.so.* by replacing it with just a check for libkdeui.so. It's been/being removed from kdevelop after 2.2. * editors/koffice: - Fix kivio compile errors by substituting in PTHREAD_LIBS in the correct place. Compensate for kivio's dependency on pthreads by changing kivio to use LD_PRELOAD=/usr/lib/libc_r.so in kivio.desktop. * games/kdegames2: - Some new games. * graphics/kdegraphics2: - Fix link errors in libkscan and kamera where they require gettext (ie: add -lintl). - Fix compile error in kamera.cpp which is dependent on a correctly done gphoto2.. of course, this will only help people who've manually installed gphoto2 themselves. * net/kdenetwork2: - Mimelib was moved here (reason for removal of kdesupport2). * misc/kdeaddons: - New module to FreeBSD ports; some simple addons for KDE2. Suggested by Lauri Watts <lauri@kde.org>. * misc/kdeutils2: - Added a couple manpages. * x11-clocks/kdetoys2: - Some new apps. * sysutils/kdeadmin: - Remove kuser from compile because it has some problems. ;\ * x11/kdelibs2: - Add libFAM dependency to help people who run FAM; FAM increases the overall desktop responsiveness. Submitted by Lauri Watts <lauri@kde.org>. - Add CUPS dependency to bring in KDE's new print system. - Add bzip2/libxml2 dependencies to support the new help kioslave. - Disable installation of libltdl stuff to prevent conflicts with other stuff. Submitted by wjv. - Add pkg-req script to avoid conflicts with kdelibs11; add to Makefile too. Submitted by benno. - Be sure to remove the pth header conflicts stuff from the arts/mcop_mt section. - Fix problem with configure trying to find -lfam in the wrong place. - Remove kspell and api subdirs from doc; we don't need them, and there are problems trying to build/install them. Submitted by Lauri Watts <lauri@kde.org>. * x11/kdebase2: - Solve link permissions problem by changing the modes on files installed by kdesktop/init/Templates to 644. Submitted by Jim Durham <durham@w2xo.pgh.pa.us>. * x11/kde2: - Bump version; no other changes. Special thanks to Lauri Watts <lauri@kde.org> for helping me test packages generated by these changes on a virgin system. I believe that this is the best-tested update I've ever done for KDE, and it really shines this time around. I just noticed there are a couple other PRs in the PR db that need to be addressed. I will take care of those by tomorrow. Sorry... PR: 22735, 28549 Blanket approval by: demon (kdesdk, kdevelop)
Diffstat (limited to 'x11/kdelibs4/Makefile')
-rw-r--r--x11/kdelibs4/Makefile27
1 files changed, 23 insertions, 4 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 07d9614b8745..f869db03e40a 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdelibs
-PORTVERSION= 2.1.2
+PORTVERSION= 2.2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/src
@@ -15,7 +15,10 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
- mimelib.3:${PORTSDIR}/converters/kdesupport2
+ fam.0:${PORTSDIR}/devel/fam \
+ cups.2:${PORTSDIR}/print/cups \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ bz2.1:${PORTSDIR}/archivers/bzip2
USE_OPENSSL= yes
USE_QT_VER= 2
@@ -24,6 +27,8 @@ SOMINOR= 0
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install \
+ --enable-debug --disable-final
.if ${MACHINE_ARCH} == "alpha"
CFLAGS= -O0 ${KDE_CFLAGS}
@@ -31,7 +36,7 @@ CFLAGS= -O0 ${KDE_CFLAGS}
USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}"
-PLIST_SUB+= LIBVER="${SOMAJOR}" RM="${RM}"
+PLIST_SUB+= LIBVER="${SOMAJOR}" LDCONFIG="${LDCONFIG}"
.include <bsd.port.pre.mk>
@@ -46,14 +51,28 @@ pre-fetch:
@${ECHO} "then KDE2 will not build with SSL support."
@${ECHO}
.endif
+.if exists(${LOCALBASE}/include/kfm.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have KDE1 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between KDE2 and KDE1!"
+ @${ECHO}
+ @${FALSE}
+.endif
pre-configure:
- ${PERL} -pi -e "s@-O2@-O0@g" ${WRKSRC}/configure
+ ${PERL} -pi -e "s@-O2@-O0@g; s@\"-lfam@\"-L${LOCALBASE}/lib -lfam@g" ${WRKSRC}/configure
+ ${PERL} -pi -e "s@kspell api@@g" ${WRKSRC}/doc/Makefile.in
(find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi.orig -e \
"s@version-info 1:0@version-info ${SOMAJOR}:${SOMINOR}@g; \
s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g")
+post-configure:
+ ${PERL} -pi -e "s@-D_PTH_H_ -D_PTH_PTHREAD_H_@@g" ${WRKSRC}/arts/mcop_mt/Makefile
+
post-install:
+ ${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/kdelibs.sh > ${PREFIX}/etc/rc.d/kdelibs.sh
.for LIB in DCOP kab kdecore kdesu kdeui kfile kformula kio kjs \
kparts kspell ksycoca kjava
@${LN} -sf ${PREFIX}/lib/lib${LIB}.so.${SOMAJOR} ${PREFIX}/lib/lib${LIB}.so