aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs4/Makefile
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-06-23 02:57:33 +0800
committerpi <pi@FreeBSD.org>2016-06-23 02:57:33 +0800
commita836abdb781bb3cb763c704e120c2a3266d97f84 (patch)
tree14a0f2235807b33e86dc0ec99cb4ac26ed7f003d /x11/kdelibs4/Makefile
parentdd65a4bdca31f99c9187c84ba9a67b545c4f45f0 (diff)
downloadfreebsd-ports-gnome-a836abdb781bb3cb763c704e120c2a3266d97f84.tar.gz
freebsd-ports-gnome-a836abdb781bb3cb763c704e120c2a3266d97f84.tar.zst
freebsd-ports-gnome-a836abdb781bb3cb763c704e120c2a3266d97f84.zip
x11/kde4: update to kdelibs version 4.14.10
This is based on the area51 testing repository of the KDE-FreeBSD project, containing work by Raphael Kubo da Costa, Tobias Berner, Ralf Nolden, Adriaan de Groot and probably many more from the KDE team. KDE4 releases have fallen into three tracks now that KDE4 is pretty much end-of-life upstream. There's the libraries, the workspace (Plasma4) and applications. This patch introduces KDE4_KDELIBS_VERSION to track library releases, which are still done infrequently. It bumps the workspace version. It leaves applications alone. This has an effect on some applications pkg-plists where library version numbers need to be changed. Other than that it's supposed to be a minor upgrade, which opens the doors for more reorganization and getting KDE Frameworks 5 in. PR: 210255 Submitted by: Adriaan de Groot <groot@kde.org> (kde), Tobias C.Berner <tcberner@gmail.com> (kde) Exp-run by: antoine
Diffstat (limited to 'x11/kdelibs4/Makefile')
-rw-r--r--x11/kdelibs4/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index c43f3b10dac0..96f2c3b3be3d 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= kdelibs
-PORTVERSION= ${KDE4_VERSION}
+PORTVERSION= ${KDE4_KDELIBS_VERSION}
PORTREVISION= 6
CATEGORIES= x11 kde
-MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
@@ -14,13 +14,11 @@ COMMENT= Base set of libraries needed by KDE programs
LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
libjasper.so:graphics/jasper \
libpcre.so:devel/pcre \
- libavahi-core.so:net/avahi-app \
libenchant.so:textproc/enchant \
libgif.so:graphics/giflib \
libpng.so:graphics/png \
libhal.so:sysutils/hal \
libqca.so:devel/qca \
- libHUpnp.so:net/hupnp \
libpolkit-qt-core-1.so:sysutils/polkit-qt \
libdbusmenu-qt.so:devel/libdbusmenu-qt \
libgrantlee_gui.so:devel/grantlee
@@ -36,7 +34,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:misc/hicolor-icon-them
USE_GNOME= libxml2 libxslt
USE_KDE4= oxygen \
attica automoc4 ontologies soprano strigi
-USES= cmake:outsource fam gettext jpeg perl5 shared-mime-info shebangfix tar:xz
+USES= cmake:outsource fam gettext jpeg perl5 shared-mime-info \
+ shebangfix tar:xz
USE_OPENSSL= yes
USE_QT4= corelib dbus declarative designer_build gui \
network opengl phonon qt3support \
@@ -52,7 +51,6 @@ CMAKE_ARGS+= -DWITH_ACL:BOOL=Off \
-DWITH_ASPELL:BOOL=Off \
-DWITH_HSPELL:BOOL=Off \
-DWITH_UDev:BOOL=Off \
- -DHUPNP_ENABLED:BOOL=On \
-DKDE_DISTRIBUTION_TEXT:STRING="${OPSYS}" \
-DKDE_DEFAULT_HOME:STRING=".kde4"
@@ -76,6 +74,15 @@ SHEBANG_FILES= kdecore/kconfig_compiler/checkkcfg.pl \
kio/proxytype.pl \
kioslave/http/kcookiejar/kcookiescfg.pl
+OPTIONS_DEFINE= AVAHI UPNP
+OPTIONS_DEFAULT=AVAHI
+
+AVAHI_LIB_DEPENDS= libavahi-core.so:${PORTSDIR}/net/avahi-app
+
+UPNP_DESC= UPnP backend for Solid (WARNING: Unstable)
+UPNP_LIB_DEPENDS= libHUpnp.so:${PORTSDIR}/net/hupnp
+UPNP_CMAKE_ON= -DHUPNP_ENABLED:BOOL=On
+
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
${PATCH_WRKSRC}/kde3support/kdeui/k3sconfig.cpp \