aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-02 17:23:03 +0800
committermiwi <miwi@FreeBSD.org>2009-04-02 17:23:03 +0800
commit803c7a4818508c95b4617cabd5caeae911b08c5c (patch)
tree03da3704e26abbb9e9ce5159c358edcb65f73029 /x11/kdelibs4
parent17fe3bdff0e2f9b34e0e06957ec1aeea3bd41ede (diff)
downloadfreebsd-ports-gnome-803c7a4818508c95b4617cabd5caeae911b08c5c.tar.gz
freebsd-ports-gnome-803c7a4818508c95b4617cabd5caeae911b08c5c.tar.zst
freebsd-ports-gnome-803c7a4818508c95b4617cabd5caeae911b08c5c.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.2.2
for FreeBSD. The official KDE 4.2.2 release changelog can be found at: http://www.kde.org/announcements/changelogs/changelog4_2_1to4_2_2.php. Also mark some ports MAKE_JOBS_SAFE. New Ports: misc/kde4-l10n-sk - Slovak
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/distinfo6
-rw-r--r--x11/kdelibs4/files/patch-kio_kfile_kpropertiesdialog.cpp18
3 files changed, 22 insertions, 4 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 3b3384f95715..89bb52ab9d81 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -61,6 +60,7 @@ QT_COMPONENTS= corelib dbus gui network opengl qt3support \
assistant svg qdbusviewer makeqpf imageformats \
qmake_build moc_build rcc_build uic_build
USE_GNOME= libxml2 libxslt
+MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DWITH_FAM:BOOL=Off \
-DKDE4_PREFIX:String=${KDE4_PREFIX}
diff --git a/x11/kdelibs4/distinfo b/x11/kdelibs4/distinfo
index 4473e34eb737..eaa8dd1f897c 100644
--- a/x11/kdelibs4/distinfo
+++ b/x11/kdelibs4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdelibs-4.2.1.tar.bz2) = fa4206dd747890c4e4283c8adb831e6c
-SHA256 (KDE/kdelibs-4.2.1.tar.bz2) = 25ee5be213c4f1ccaf6f19a1a2375c3b23f6e2b4602a45542758e58782a0864d
-SIZE (KDE/kdelibs-4.2.1.tar.bz2) = 10049614
+MD5 (KDE/kdelibs-4.2.2.tar.bz2) = ff54817efef952e8812c607f5089c2e1
+SHA256 (KDE/kdelibs-4.2.2.tar.bz2) = 1760487c7db92dfd98dd0a455ac65775764c43c0e696b9b8b32e87b6d3c4315c
+SIZE (KDE/kdelibs-4.2.2.tar.bz2) = 10051297
diff --git a/x11/kdelibs4/files/patch-kio_kfile_kpropertiesdialog.cpp b/x11/kdelibs4/files/patch-kio_kfile_kpropertiesdialog.cpp
new file mode 100644
index 000000000000..c092f49144c9
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kio_kfile_kpropertiesdialog.cpp
@@ -0,0 +1,18 @@
+--- ../kio/kfile/kpropertiesdialog.cpp.orig 2009-03-26 17:44:17.000000000 +0300
++++ ../kio/kfile/kpropertiesdialog.cpp 2009-04-02 10:12:09.000000000 +0400
+@@ -1770,7 +1770,15 @@
+ // pick the groups to which the user belongs
+ int groupCount = 0;
+ gid_t *groups = NULL;
++#ifdef Q_OS_FREEBSD
++#include <osreldate.h>
++#if (__FreeBSD_version <= 800000) // Fixed in kern/114655
++ gid_t tmp_group;
++ if (getgrouplist(strUser, user->pw_gid, &tmp_group, &groupCount) < 0) {
++#endif
++#else
+ if (getgrouplist(strUser, user->pw_gid, NULL, &groupCount) < 0) {
++#endif
+ groups = new gid_t[groupCount];
+ if (groups) {
+ getgrouplist(strUser, user->pw_gid, groups, &groupCount);