aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libXres/Makefile
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 08:23:26 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 08:23:26 +0800
commit15ff879858816b5f3b3d244651efb2ae9d8adb61 (patch)
treeb3bf3fe084fcb8500d2df2186729ee8d4cf7d7ba /x11/libXres/Makefile
parent7d3df55707597cfd31316831d3b0b7921c31f4b5 (diff)
downloadfreebsd-ports-gnome-15ff879858816b5f3b3d244651efb2ae9d8adb61.tar.gz
freebsd-ports-gnome-15ff879858816b5f3b3d244651efb2ae9d8adb61.tar.zst
freebsd-ports-gnome-15ff879858816b5f3b3d244651efb2ae9d8adb61.zip
New port: Prerelease version of libXres from freedesktop.org:
X Resource usage library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11/libXres/Makefile')
-rw-r--r--x11/libXres/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/libXres/Makefile b/x11/libXres/Makefile
new file mode 100644
index 000000000000..7f4945a7e7d7
--- /dev/null
+++ b/x11/libXres/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXres
+PORTVERSION= 1.0.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Resource usage library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/resourceext.pc:${PORTSDIR}/x11/resourceext \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>