aboutsummaryrefslogtreecommitdiffstats
path: root/x11/lxhotkey
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2017-01-25 05:49:05 +0800
committerolivierd <olivierd@FreeBSD.org>2017-01-25 05:49:05 +0800
commitefa9ff0bc36aa557d005062346215b40b5427a91 (patch)
tree12fd0d8e434e15738c4c2480fbf3610cd1a2383b /x11/lxhotkey
parent0c9811f228537eb8e4dc2101e572414aa82d84a8 (diff)
downloadfreebsd-ports-gnome-efa9ff0bc36aa557d005062346215b40b5427a91.tar.gz
freebsd-ports-gnome-efa9ff0bc36aa557d005062346215b40b5427a91.tar.zst
freebsd-ports-gnome-efa9ff0bc36aa557d005062346215b40b5427a91.zip
LXHotkey is an universal application for the Lightweight X11 Desktop
Environment (LXDE) which allows view and change global keyboard shortcuts for Window Manager actions, including ones to start applications. WWW: http://www.lxde.org/
Diffstat (limited to 'x11/lxhotkey')
-rw-r--r--x11/lxhotkey/Makefile31
-rw-r--r--x11/lxhotkey/distinfo3
-rw-r--r--x11/lxhotkey/pkg-descr5
-rw-r--r--x11/lxhotkey/pkg-plist15
4 files changed, 54 insertions, 0 deletions
diff --git a/x11/lxhotkey/Makefile b/x11/lxhotkey/Makefile
new file mode 100644
index 000000000000..c2245c11d07a
--- /dev/null
+++ b/x11/lxhotkey/Makefile
@@ -0,0 +1,31 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= lxhotkey
+PORTVERSION= 0.1.0
+CATEGORIES= x11
+MASTER_SITES= SF/lxde/LXHotkey/
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Keyboard shortcuts settings
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfm-extra.so:x11/libfm-extra \
+ libfm.so:x11/libfm \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libunistring.so:devel/libunistring
+
+USES= gettext-tools gmake pathfix pkgconfig tar:xz
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk20 intltool cairo gdkpixbuf2
+USE_XORG= x11
+
+CONFIGURE_ARGS= --with-gtk=2
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lxhotkey/*.so
+
+.include <bsd.port.mk>
diff --git a/x11/lxhotkey/distinfo b/x11/lxhotkey/distinfo
new file mode 100644
index 000000000000..d0510833ac33
--- /dev/null
+++ b/x11/lxhotkey/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485195764
+SHA256 (lxhotkey-0.1.0.tar.xz) = 35dd6c75790e3a986fbb931c12838b3a554ad23597dd3878de8d6f49c3129748
+SIZE (lxhotkey-0.1.0.tar.xz) = 271836
diff --git a/x11/lxhotkey/pkg-descr b/x11/lxhotkey/pkg-descr
new file mode 100644
index 000000000000..40268a5d87da
--- /dev/null
+++ b/x11/lxhotkey/pkg-descr
@@ -0,0 +1,5 @@
+LXHotkey is an universal application for the Lightweight X11 Desktop
+Environment (LXDE) which allows view and change global keyboard shortcuts
+for Window Manager actions, including ones to start applications.
+
+WWW: http://www.lxde.org/
diff --git a/x11/lxhotkey/pkg-plist b/x11/lxhotkey/pkg-plist
new file mode 100644
index 000000000000..348f9fd48b8d
--- /dev/null
+++ b/x11/lxhotkey/pkg-plist
@@ -0,0 +1,15 @@
+bin/lxhotkey
+include/lxhotkey/lxhotkey.h
+lib/locale/cs/LC_MESSAGES/lxhotkey.mo
+lib/locale/gl/LC_MESSAGES/lxhotkey.mo
+lib/locale/nl/LC_MESSAGES/lxhotkey.mo
+lib/locale/pt/LC_MESSAGES/lxhotkey.mo
+lib/locale/ru/LC_MESSAGES/lxhotkey.mo
+lib/locale/sr/LC_MESSAGES/lxhotkey.mo
+lib/locale/sr@latin/LC_MESSAGES/lxhotkey.mo
+lib/locale/uk/LC_MESSAGES/lxhotkey.mo
+lib/lxhotkey/gtk.so
+lib/lxhotkey/ob.so
+libdata/pkgconfig/lxhotkey.pc
+man/man1/lxhotkey.1.gz
+share/applications/lxhotkey-gtk.desktop