aboutsummaryrefslogtreecommitdiffstats
path: root/x11/lxpanel
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2010-12-21 04:06:38 +0800
committerKris Moore <kmoore@FreeBSD.org>2010-12-21 04:06:38 +0800
commit44f0823ff03880254a2b80190a7049dc44a6b8fe (patch)
tree336d7caf488860858b948495597e27c579871dc3 /x11/lxpanel
parent4001f01e8dfeb621c1559ca82679a29ed09e9f9a (diff)
downloadfreebsd-ports-gnome-44f0823ff03880254a2b80190a7049dc44a6b8fe.tar.gz
freebsd-ports-gnome-44f0823ff03880254a2b80190a7049dc44a6b8fe.tar.zst
freebsd-ports-gnome-44f0823ff03880254a2b80190a7049dc44a6b8fe.zip
Fix lx_alarm bug which also caused issue compiling on 8.x and bump PORTREVISION.
Diffstat (limited to 'x11/lxpanel')
-rw-r--r--x11/lxpanel/Makefile2
-rw-r--r--x11/lxpanel/files/patch-src__plugins__batt__batt.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 3ad0b9bdfb6d..c22b8795bd61 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lxpanel
PORTVERSION= 0.5.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}
diff --git a/x11/lxpanel/files/patch-src__plugins__batt__batt.c b/x11/lxpanel/files/patch-src__plugins__batt__batt.c
index f94f9f493fa3..34a4d5526bd8 100644
--- a/x11/lxpanel/files/patch-src__plugins__batt__batt.c
+++ b/x11/lxpanel/files/patch-src__plugins__batt__batt.c
@@ -76,7 +76,7 @@
if (alarmCanRun) {
- alarm *a = (alarm *) malloc(sizeof(alarm));
-+ lx_alarm *a = (lx_alarm *) malloc(sizeof(alarm));
++ lx_alarm *a = (lx_alarm *) malloc(sizeof(lx_alarm));
a->command = lx_b->alarmCommand;
a->lock = &(lx_b->alarmProcessLock);