aboutsummaryrefslogtreecommitdiffstats
path: root/x11/mlterm
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2012-10-25 20:34:06 +0800
committernobutaka <nobutaka@FreeBSD.org>2012-10-25 20:34:06 +0800
commitb69288f9133895de923fb3f61d6e6dd00ecddbe6 (patch)
tree98d962e2f2896019998c1f59244827d62fcac8f5 /x11/mlterm
parentced8e1e4ac731eee53b36ab646cfa3d245fa6f0f (diff)
downloadfreebsd-ports-gnome-b69288f9133895de923fb3f61d6e6dd00ecddbe6.tar.gz
freebsd-ports-gnome-b69288f9133895de923fb3f61d6e6dd00ecddbe6.tar.zst
freebsd-ports-gnome-b69288f9133895de923fb3f61d6e6dd00ecddbe6.zip
Update to 3.1.4.
Feature safe: yes
Diffstat (limited to 'x11/mlterm')
-rw-r--r--x11/mlterm/Makefile32
-rw-r--r--x11/mlterm/distinfo4
-rw-r--r--x11/mlterm/files/patch-kiklib_src_kik_utmp_utmper.c13
-rw-r--r--x11/mlterm/files/patch-main_dexport.map11
4 files changed, 19 insertions, 41 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 007c594d5a59..544dd29ca193 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mlterm
-PORTVERSION= 3.1.3
+PORTVERSION= 3.1.4
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/01release/${PORTNAME}-${PORTVERSION}
@@ -28,17 +28,19 @@ CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf2 --enable-utmp \
CONFIGURE_ENV= LIBS="${LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl"
CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
-OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
- UIM "uim support (experimental)" off \
- M17NLIB "m17n library support (experimental)" off \
- SCIM "SCIM support (experimental)" off \
- IBUS "IBUS support (experimental)" off \
- CAIRO "Use Cairo for type engine (experimental)" off \
- SIXEL "Sixel graphics support" off
+
+OPTIONS_DEFINE= CAIRO FRIBIDI IBUS M17NLIB SCIM SIXEL UIM
+CAIRO_DESC= "Use Cairo for type engine (experimental)"
+FRIBIDI_DESC= "Use Fribidi for BiDi rendering"
+IBUS_DESC= "IBUS support (experimental)"
+M17NLIB_DESC= "m17n library support (experimental)"
+SCIM_DESC= "SCIM support (experimental)"
+SIXEL_DESC= "Sixel graphics support"
+UIM_DESC= "uim support (experimental)"
.include <bsd.port.pre.mk>
-.if defined(WITH_FRIBIDI)
+.if ${PORT_OPTIONS:MFRIBIDI}
CONFIGURE_ARGS+= --enable-fribidi
LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
PLIST_SUB+= FRIBIDI=""
@@ -47,7 +49,7 @@ CONFIGURE_ARGS+= --disable-fribidi
PLIST_SUB+= FRIBIDI="@comment "
.endif
-.if defined(WITH_UIM)
+.if ${PORT_OPTIONS:MUIM}
CONFIGURE_ARGS+= --enable-uim
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= uim:${PORTSDIR}/textproc/uim
@@ -57,7 +59,7 @@ CONFIGURE_ARGS+= --disable-uim
PLIST_SUB+= UIM="@comment "
.endif
-.if defined(WITH_M17NLIB)
+.if ${PORT_OPTIONS:MM17NLIB}
CONFIGURE_ARGS+= --enable-m17nlib
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= m17n:${PORTSDIR}/devel/m17n-lib
@@ -67,7 +69,7 @@ CONFIGURE_ARGS+= --disable-m17nlib
PLIST_SUB+= M17NLIB="@comment "
.endif
-.if defined(WITH_SCIM)
+.if ${PORT_OPTIONS:MSCIM}
CONFIGURE_ARGS+= --enable-scim
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= scim-1.0:${PORTSDIR}/textproc/scim
@@ -77,7 +79,7 @@ CONFIGURE_ARGS+= --disable-scim
PLIST_SUB+= SCIM="@comment "
.endif
-.if defined(WITH_IBUS)
+.if ${PORT_OPTIONS:MIBUS}
CONFIGURE_ARGS+= --enable-ibus
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= ibus-1.0:${PORTSDIR}/textproc/ibus
@@ -87,7 +89,7 @@ CONFIGURE_ARGS+= --disable-ibus
PLIST_SUB+= IBUS="@comment "
.endif
-.if defined(WITH_CAIRO)
+.if ${PORT_OPTIONS:MCAIRO}
CONFIGURE_ARGS+= --with-type-engines="xcore,xft,cairo"
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
@@ -97,7 +99,7 @@ CONFIGURE_ARGS+= --with-type-engines="xcore,xft"
PLIST_SUB+= CAIRO="@comment "
.endif
-.if defined(WITH_SIXEL)
+.if ${PORT_OPTIONS:MSIXEL}
CONFIGURE_ARGS+= --enable-sixel
PLIST_SUB+= SIXEL=""
.else
diff --git a/x11/mlterm/distinfo b/x11/mlterm/distinfo
index b50b981c91a0..ebf2749efa69 100644
--- a/x11/mlterm/distinfo
+++ b/x11/mlterm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mlterm-3.1.3.tar.gz) = 43dcefefaa6e43fcf92da9a905f3a7e2479e02763cb03bfb95c3ac1ca4403f28
-SIZE (mlterm-3.1.3.tar.gz) = 4362011
+SHA256 (mlterm-3.1.4.tar.gz) = f47fc0a138a4295b0745624d6ca30cb5f06545858d8c1f9183262330e73a0347
+SIZE (mlterm-3.1.4.tar.gz) = 3454873
diff --git a/x11/mlterm/files/patch-kiklib_src_kik_utmp_utmper.c b/x11/mlterm/files/patch-kiklib_src_kik_utmp_utmper.c
deleted file mode 100644
index 1163f3d81722..000000000000
--- a/x11/mlterm/files/patch-kiklib_src_kik_utmp_utmper.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- kiklib/src/kik_utmp_utmper.c.orig 2012-04-29 11:38:18.000000000 +0900
-+++ kiklib/src/kik_utmp_utmper.c 2012-04-29 11:39:57.000000000 +0900
-@@ -20,8 +20,8 @@
-
- kik_utmp_t
- kik_utmp_new(
-- char * tty ,
-- char * host,
-+ const char * tty ,
-+ const char * host,
- int pty_fd
- )
- {
diff --git a/x11/mlterm/files/patch-main_dexport.map b/x11/mlterm/files/patch-main_dexport.map
deleted file mode 100644
index d69a4adee4e4..000000000000
--- a/x11/mlterm/files/patch-main_dexport.map
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/dexport.map.orig 2012-04-29 11:45:34.000000000 +0900
-+++ main/dexport.map 2012-04-29 11:46:34.000000000 +0900
-@@ -2,6 +2,8 @@
- global:
- x_imagelib_load_file ;
- x_get_opened_displays ;
-+ __progname ;
-+ environ ;
- local:
- * ;
- } ;