aboutsummaryrefslogtreecommitdiffstats
path: root/x11/multi-gnome-terminal/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-08-22 22:53:23 +0800
committermarcus <marcus@FreeBSD.org>2002-08-22 22:53:23 +0800
commitc1bfcc4aa05e42e8204c71555457a41f61af1c43 (patch)
tree0bf382042e015a26dacd3933d5f2e633fa7cd6a1 /x11/multi-gnome-terminal/Makefile
parent4236c498f314dc5ea346a6a01d1dc73dfcac9c57 (diff)
downloadfreebsd-ports-gnome-c1bfcc4aa05e42e8204c71555457a41f61af1c43.tar.gz
freebsd-ports-gnome-c1bfcc4aa05e42e8204c71555457a41f61af1c43.tar.zst
freebsd-ports-gnome-c1bfcc4aa05e42e8204c71555457a41f61af1c43.zip
* Use USE_GNOMENG
* Properly place files under GNOME hierarchy * Install an icon in ${PREFIX}/share/gnome/pixmaps * Bump PORTREVISION Approved by: timeout from maintainer
Diffstat (limited to 'x11/multi-gnome-terminal/Makefile')
-rw-r--r--x11/multi-gnome-terminal/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11/multi-gnome-terminal/Makefile b/x11/multi-gnome-terminal/Makefile
index 76b65c44c178..1707f104380c 100644
--- a/x11/multi-gnome-terminal/Makefile
+++ b/x11/multi-gnome-terminal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= multi-gnome-terminal
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://multignometerm.sourceforge.net/
@@ -14,19 +15,16 @@ MASTER_SITE_SUBDIR= multignometerm
MAINTAINER= fdubuy@free.fr
-BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
-LIB_DEPENDS+= xml.5:${PORTSDIR}/textproc/libxml \
- ORBit.2:${PORTSDIR}/devel/ORBit
-RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
-
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
USE_GMAKE= yes
GNU_CONFIGURE= yes
-# The distribution Makefile.in files append "/gnome" to --datadir
-CONFIGURE_ARGS+= --datadir=${PREFIX}/share
MAN1= multi-gnome-terminal.1
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/pixmaps/multignometerm.png \
+ ${PREFIX}/share/gnome/pixmaps/multignometerm.png
+
.include <bsd.port.mk>