aboutsummaryrefslogtreecommitdiffstats
path: root/x11/nvidia-driver
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-03-14 15:09:10 +0800
committerdanfe <danfe@FreeBSD.org>2011-03-14 15:09:10 +0800
commitd64a534b054c2241b120340f5c0b3fc5febd8931 (patch)
treeae2733024742c7011e228809237ed9e823e0df6a /x11/nvidia-driver
parent125a1787962b2b5548de913a30b389ba70edb2d5 (diff)
downloadfreebsd-ports-gnome-d64a534b054c2241b120340f5c0b3fc5febd8931.tar.gz
freebsd-ports-gnome-d64a534b054c2241b120340f5c0b3fc5febd8931.tar.zst
freebsd-ports-gnome-d64a534b054c2241b120340f5c0b3fc5febd8931.zip
Now that PKG_INFO macro expands correctly on all supported versions of
FreeBSD, use it as advised by common sense and XXX statement. PR: ports/125996 Submitted by: edwin
Diffstat (limited to 'x11/nvidia-driver')
-rw-r--r--x11/nvidia-driver/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index fe5dd47af964..07eca02a9a9c 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -10,13 +10,13 @@ DISTVERSION?= 256.53
PORTREVISION?= 1 # As a reminder it can be overridden
CATEGORIES= x11 kld
MASTER_SITES= ${MASTER_SITE_NVIDIA}
-ARCH_SUFX= ${ARCH:S/i386//:S/amd/_/}
# MASTER_SITE_SUBDIR has to be set later because it depends on NVVERSION
DISTNAME= NVIDIA-FreeBSD-x86${ARCH_SUFX}-${DISTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= NVidia graphics card binary drivers for hardware OpenGL rendering
+ARCH_SUFX= ${ARCH:S/i386//:S/amd/_/}
NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
USE_GL= gl
USE_LDCONFIG= yes
@@ -57,10 +57,8 @@ OPTIONS+= WBINVD "Enable heavy-weight cache-flush logic" off
.include <bsd.port.pre.mk>
-# XXX Should use ${PKG_INFO} but it does not expand for some reason XXX
-#
-XSERVVERSION!= /usr/sbin/pkg_info -qO x11-servers/xorg-server 2>/dev/null || true
-LIBGLVERSION!= /usr/sbin/pkg_info -qO graphics/libGL 2>/dev/null || true
+XSERVVERSION!= ${PKG_INFO} -qO x11-servers/xorg-server 2>/dev/null || true
+LIBGLVERSION!= ${PKG_INFO} -qO graphics/libGL 2>/dev/null || true
.if empty(XSERVVERSION)
IGNORE= needs an X server implementation installed