aboutsummaryrefslogtreecommitdiffstats
path: root/x11/sessreg
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-01 19:41:07 +0800
committerMartin Wilke <miwi@FreeBSD.org>2010-05-01 19:41:07 +0800
commitf4936121f95e76555bebbc39e5b73dc12b0ff91f (patch)
treefcac9880f7998d69245463508464761e7b89a20e /x11/sessreg
parent693ef828a26aa5cb92848177be5fcb2afa9dd055 (diff)
downloadfreebsd-ports-gnome-f4936121f95e76555bebbc39e5b73dc12b0ff91f.tar.gz
freebsd-ports-gnome-f4936121f95e76555bebbc39e5b73dc12b0ff91f.tar.zst
freebsd-ports-gnome-f4936121f95e76555bebbc39e5b73dc12b0ff91f.zip
- Update to Xorg 7.5
The Intel drivers was patched to work with the new server. The drivers for Vesa, NV,NVIDIA and ATI have been tested thoroughfully and seem to work fine. A complete changelog of Xorg 7.5 can you read here: http://www.x.org/releases/X11R7.5/ A note to FreeBSD 6.X users: We strongly recommend you to update your system to 7.x or above. For updating try portupgrade -af \* or: portmaster -af Please report any problems and issus to x11 (at) FreeBSD.org. Thanks to beat@, rnoland@, fluffy@, stas@ and all testers for their help and Feeback. Tested by: Community and 2x exp-runs
Diffstat (limited to 'x11/sessreg')
-rw-r--r--x11/sessreg/Makefile2
-rw-r--r--x11/sessreg/distinfo6
-rw-r--r--x11/sessreg/files/patch-utmpx68
3 files changed, 38 insertions, 38 deletions
diff --git a/x11/sessreg/Makefile b/x11/sessreg/Makefile
index 03de0618f141..b7f12836029b 100644
--- a/x11/sessreg/Makefile
+++ b/x11/sessreg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sessreg
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
diff --git a/x11/sessreg/distinfo b/x11/sessreg/distinfo
index d300de9c3d59..226ac2586014 100644
--- a/x11/sessreg/distinfo
+++ b/x11/sessreg/distinfo
@@ -1,3 +1,3 @@
-MD5 (xorg/app/sessreg-1.0.4.tar.bz2) = 839e968d7197b9563f0fd8a5a3aac2e3
-SHA256 (xorg/app/sessreg-1.0.4.tar.bz2) = 23e163502e208ac16f04a12b15f7f8dcd9919f0149c714353b7f92539b7e9802
-SIZE (xorg/app/sessreg-1.0.4.tar.bz2) = 96209
+MD5 (xorg/app/sessreg-1.0.5.tar.bz2) = 00e834c3cbfd990e9d7d5ddc834242df
+SHA256 (xorg/app/sessreg-1.0.5.tar.bz2) = 3308fbd0018d53bb818fee9de1cde484965b740073d5d240efa4cfc881c9d1a9
+SIZE (xorg/app/sessreg-1.0.5.tar.bz2) = 103142
diff --git a/x11/sessreg/files/patch-utmpx b/x11/sessreg/files/patch-utmpx
index 67fdf2974975..7ae4da842dbd 100644
--- a/x11/sessreg/files/patch-utmpx
+++ b/x11/sessreg/files/patch-utmpx
@@ -1,6 +1,6 @@
---- configure.ac
-+++ configure.ac
-@@ -39,13 +39,14 @@ AC_PROG_INSTALL
+--- configure.ac.orig 2009-10-12 13:10:57.000000000 -0500
++++ configure.ac 2010-03-27 08:12:08.000000000 -0500
+@@ -39,13 +39,14 @@
XORG_DEFAULT_OPTIONS
@@ -16,9 +16,9 @@
AC_SYS_LARGEFILE
---- sessreg.c
-+++ sessreg.c
-@@ -80,7 +80,6 @@
+--- sessreg.c.orig 2009-10-12 12:52:12.000000000 -0500
++++ sessreg.c 2010-03-27 08:13:46.000000000 -0500
+@@ -81,7 +81,6 @@
# include <X11/Xfuncs.h>
# include <stdio.h>
# include <stdlib.h>
@@ -26,7 +26,7 @@
#if defined(__SVR4) || defined(SVR4) || defined(linux) || defined(__GLIBC__)
# define SYSV
-@@ -89,7 +88,10 @@
+@@ -90,7 +89,10 @@
#include <time.h>
#define Time_t time_t
@@ -38,9 +38,9 @@
#ifdef USE_UTMPX
static void set_utmpx (struct utmpx *u, const char *line, const char *user,
-@@ -99,7 +101,12 @@
- int wflag, uflag, lflag;
- char *wtmp_file, *utmp_file, *line;
+@@ -100,7 +102,12 @@
+ static int wflag, uflag, lflag;
+ static char *wtmp_file, *utmp_file, *line;
#ifdef USE_UTMPX
-static char *wtmpx_file = NULL, *utmpx_file = NULL;
+#ifdef HAVE_UPDWTMPX
@@ -50,19 +50,19 @@
+static char *utmpx_file = NULL;
+#endif
#endif
- int utmp_none, wtmp_none;
+ static int utmp_none, wtmp_none;
/*
-@@ -108,7 +115,9 @@
+@@ -109,7 +116,9 @@
*/
- int hflag, sflag, xflag, tflag;
- char *host_name = NULL;
+ static int hflag, sflag, xflag, tflag;
+ static char *host_name = NULL;
+#ifdef USE_UTMP
- int slot_number;
+ static int slot_number;
+#endif
- char *xservers_file, *ttys_file;
- char *user_name;
- int aflag, dflag;
-@@ -180,7 +189,7 @@
+ static char *xservers_file, *ttys_file;
+ static char *user_name;
+ static int aflag, dflag;
+@@ -181,7 +190,7 @@
int
main (int argc, char **argv)
{
@@ -71,7 +71,7 @@
int utmp;
#endif
char *line_tmp;
-@@ -188,7 +197,9 @@
+@@ -189,7 +198,9 @@
int wtmp;
#endif
Time_t current_time;
@@ -81,7 +81,7 @@
#ifdef USE_UTMPX
struct utmpx utmpx_entry;
#endif
-@@ -223,7 +234,9 @@
+@@ -224,7 +235,9 @@
host_name = getstring (&argv, &hflag);
break;
case 's':
@@ -91,7 +91,7 @@
break;
case 'x':
xservers_file = getstring (&argv, &xflag);
-@@ -249,14 +262,14 @@
+@@ -250,14 +263,14 @@
/* set up default file names */
if (!wflag) {
wtmp_file = WTMP_FILE;
@@ -108,7 +108,7 @@
utmpx_file = UTMPX_FILE;
#endif
}
-@@ -267,7 +280,7 @@
+@@ -268,7 +281,7 @@
if (!Lflag)
llog_file = LLOG_FILE;
#endif
@@ -117,7 +117,7 @@
if (!tflag)
ttys_file = TTYS_FILE;
if (!sflag && !utmp_none) {
-@@ -286,34 +299,42 @@
+@@ -287,34 +300,42 @@
line = line_tmp;
}
time (&current_time);
@@ -163,7 +163,7 @@
utmp = open (utmp_file, O_RDWR);
if (utmp != -1) {
syserr ((int) lseek (utmp, (long) slot_number * sizeof (struct utmp), 0), "lseek");
-@@ -321,13 +342,16 @@
+@@ -322,13 +343,16 @@
== sizeof (utmp_entry), "write utmp entry");
close (utmp);
}
@@ -181,7 +181,7 @@
#else
wtmp = open (wtmp_file, O_WRONLY|O_APPEND);
if (wtmp != -1) {
-@@ -370,6 +394,7 @@
+@@ -371,6 +395,7 @@
* fill in the appropriate records of the utmp entry
*/
@@ -189,7 +189,7 @@
static void
set_utmp (struct utmp *u, char *line, char *user, char *host, Time_t date, int addp)
{
-@@ -416,6 +441,7 @@
+@@ -417,6 +442,7 @@
#endif
u->ut_time = date;
}
@@ -197,7 +197,7 @@
#ifdef USE_UTMPX
static int
-@@ -423,6 +449,8 @@
+@@ -424,6 +450,8 @@
{
struct utmpx *u; /* pointer to entry in utmp file */
int status = 1; /* return code */
@@ -206,7 +206,7 @@
while ( (u = getutxent()) != NULL ) {
-@@ -434,7 +462,7 @@
+@@ -435,7 +463,7 @@
}
}
@@ -215,7 +215,7 @@
return (status);
}
-@@ -453,14 +481,16 @@
+@@ -454,14 +482,16 @@
(void) strncpy (u->ut_line, line, sizeof (u->ut_line));
strncpy(u->ut_host, line, sizeof(u->ut_host));
@@ -234,7 +234,7 @@
if (line) {
int i;
-@@ -519,7 +549,7 @@
+@@ -520,7 +550,7 @@
}
#endif /* USE_UTMPX */
@@ -243,9 +243,9 @@
/*
* compute the slot-number for an X display. This is computed
* by counting the lines in /etc/ttys and adding the line-number
---- sessreg.h
-+++ sessreg.h
-@@ -51,13 +51,15 @@
+--- sessreg.h.orig 2008-06-11 16:30:54.000000000 -0500
++++ sessreg.h 2010-03-27 08:12:08.000000000 -0500
+@@ -57,13 +57,15 @@
#include <sys/types.h>
#include <time.h>