aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yelp/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-08-06 03:13:24 +0800
committerkwm <kwm@FreeBSD.org>2015-08-06 03:13:24 +0800
commitbc6e07a29987571d80b4d847a2dc03a3b52e9d60 (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /x11/yelp/Makefile
parentef524082a34d7a98c929937172fd0785d168ad45 (diff)
downloadfreebsd-ports-gnome-bc6e07a29987571d80b4d847a2dc03a3b52e9d60.tar.gz
freebsd-ports-gnome-bc6e07a29987571d80b4d847a2dc03a3b52e9d60.tar.zst
freebsd-ports-gnome-bc6e07a29987571d80b4d847a2dc03a3b52e9d60.zip
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.
The offical GNOME 3.16 release notes can be found at https://help.gnome.org/misc/release-notes/3.16/ Upgrade instructions for port users: Delete the old tracker package with: # pkg delete -f tracker And user port upgrade tool of choice to upgrade. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 201980
Diffstat (limited to 'x11/yelp/Makefile')
-rw-r--r--x11/yelp/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index a1ae4bc2ddc6..d1819a9eaf72 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -1,9 +1,8 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11/yelp/Makefile 19967 2014-10-16 06:45:29Z gusi $
PORTNAME= yelp
-PORTVERSION= 3.14.1
+PORTVERSION= 3.16.1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,19 +18,25 @@ BUILD_DEPENDS= yelp-xsl>=0:${PORTSDIR}/textproc/yelp-xsl \
LIB_DEPENDS= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
RUN_DEPENDS= yelp-xsl>=0:${PORTSDIR}/textproc/yelp-xsl
+PORTSCOUT= limitw:1,even
+
USES= desktop-file-utils gettext gmake libtool pathfix \
pkgconfig tar:xz
USE_XORG= x11 ice
-USE_GNOME= gnomeprefix gtk30 intlhack libxml2 libxslt
+USE_GNOME= gtk30 intlhack libxml2 libxslt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
+LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.yelp.gschema.xml
INSTALL_TARGET= install-strip
+.include <bsd.port.options.mk>
+
+.if !exists(/usr/libdata/pkgconfig/liblzma.pc)
CONFIGURE_ENV+= YELP_LZMA_CFLAGS="-I/usr/include" \
YELP_LZMA_LIBS="-L/usr/lib -llzma"
+.endif
.include <bsd.port.mk>