aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2005-05-13 23:00:44 +0800
committerbms <bms@FreeBSD.org>2005-05-13 23:00:44 +0800
commit0410d34ab17e6539cc5ef6440781a75a1b32316e (patch)
tree6490cdb0525b0b3ccc9855e24d70f8e0e37b7162 /x11
parentddf9b8f2444900f73cdcd109c7f38e333d82611a (diff)
downloadfreebsd-ports-gnome-0410d34ab17e6539cc5ef6440781a75a1b32316e.tar.gz
freebsd-ports-gnome-0410d34ab17e6539cc5ef6440781a75a1b32316e.tar.zst
freebsd-ports-gnome-0410d34ab17e6539cc5ef6440781a75a1b32316e.zip
Update to version 2.6b6.
Don't remove uniqueid if the package is uninstalled. Update RUN_DEPENDS; xsetbg may also be found in ports/x11/xloadimage now. Use DATADIR. Note to maintainers of x11/xloadimage and graphics/xli: there is no CONFLICTS definition for those ports. Approved by: maintainer (dyeske)
Diffstat (limited to 'x11')
-rw-r--r--x11/electricsheep/Makefile27
-rw-r--r--x11/electricsheep/distinfo4
-rw-r--r--x11/electricsheep/pkg-plist20
3 files changed, 29 insertions, 22 deletions
diff --git a/x11/electricsheep/Makefile b/x11/electricsheep/Makefile
index fbeb22cf9291..96c5cb6b1c46 100644
--- a/x11/electricsheep/Makefile
+++ b/x11/electricsheep/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= electricsheep
-PORTVERSION= 2.5
-PORTREVISION= 1
+PORTVERSION= 2.6b6
CATEGORIES= x11
MASTER_SITES= http://electricsheep.org/
@@ -18,7 +17,7 @@ LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
- xsetbg:${PORTSDIR}/graphics/xli \
+ xsetbg:${PORTSDIR}/x11/xloadimage \
curl:${PORTSDIR}/ftp/curl
.if defined(WITH_XSCREENSAVER)
@@ -37,7 +36,7 @@ MAN1= electricsheep.1
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
-LIBTOOLFILES= configure mpeg2dec/configure flame/configure
+LIBTOOLFILES= configure mpeg2dec/configure flam3/configure
pre-everything::
.if !defined(WITH_XSCREENSAVER)
@@ -62,7 +61,7 @@ post-patch:
${WRKSRC}/mpeg2dec/libvo/video_out_sdl.c
@${REINPLACE_CMD} -e \
- 's|/usr/local/share|${PREFIX}/share/electricsheep|' \
+ 's|/usr/local/share|${DATADIR}|' \
${WRKSRC}/electricsheep.c
@${REINPLACE_CMD} -e \
@@ -72,13 +71,16 @@ post-patch:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/electricsheep ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/flame/anim-flame ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/flame/convert-flame ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/flame/hqi-flame ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/flame/pick-flame ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/electricsheep-voter ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/uniqueid ${PREFIX}/bin/esheep-uniqueid
+ @${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-animate ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-convert ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-genome ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/flam3/flam3-render ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/mpeg2dec/src/mpeg2dec_onroot ${PREFIX}/bin
- @${INSTALL} -d -m 0755 ${PREFIX}/share/electricsheep
- @${INSTALL_DATA} ${WRKSRC}/*.tif ${PREFIX}/share/electricsheep
+ @${INSTALL} -d -m 0755 ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.png ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.tif ${DATADIR}
.if defined(WITH_XSCREENSAVER)
@${INSTALL_DATA} ${WRKSRC}/electricsheep.xml ${PREFIX}/share/xscreensaver/config
.endif
@@ -86,4 +88,7 @@ do-install:
@${INSTALL_MAN} ${WRKSRC}/electricsheep.man ${PREFIX}/man/man1/electricsheep.1
.endif
+post-install:
+ @${PREFIX}/bin/esheep-uniqueid > ${DATADIR}/electricsheep-uniqueid
+
.include <bsd.port.mk>
diff --git a/x11/electricsheep/distinfo b/x11/electricsheep/distinfo
index b075e4d3f57e..192fa9eb5a7d 100644
--- a/x11/electricsheep/distinfo
+++ b/x11/electricsheep/distinfo
@@ -1,2 +1,2 @@
-MD5 (electricsheep-2.5.tar.gz) = 310aad5d3e4d58e823b24a28791aa553
-SIZE (electricsheep-2.5.tar.gz) = 618906
+MD5 (electricsheep-2.6b6.tar.gz) = 343a8a5704f2ae8243fd82f3796ce50f
+SIZE (electricsheep-2.6b6.tar.gz) = 1518622
diff --git a/x11/electricsheep/pkg-plist b/x11/electricsheep/pkg-plist
index f55e25614a76..713926dfac76 100644
--- a/x11/electricsheep/pkg-plist
+++ b/x11/electricsheep/pkg-plist
@@ -1,11 +1,13 @@
bin/electricsheep
-bin/convert-flame
+bin/electricsheep-voter
bin/mpeg2dec_onroot
-bin/hqi-flame
-bin/anim-flame
-bin/pick-flame
-share/electricsheep/electricsheep-frown.tif
-share/electricsheep/electricsheep-smile.tif
-share/electricsheep/electricsheep-splash-0.tif
-share/electricsheep/electricsheep-splash-1.tif
-@dirrm share/electricsheep
+bin/flam3-animate
+bin/flam3-convert
+bin/flam3-genome
+bin/flam3-render
+bin/esheep-uniqueid
+%%DATADIR%%/electricsheep-frown.png
+%%DATADIR%%/electricsheep-smile.png
+%%DATADIR%%/electricsheep-splash-0.tif
+%%DATADIR%%/electricsheep-splash-1.tif
+@unexec rmdir %%DATADIR%% 2>/dev/null || true