aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2008-03-02 23:03:05 +0800
committerdanfe <danfe@FreeBSD.org>2008-03-02 23:03:05 +0800
commit0885e720fa63eee312662781c808ebeae807c73d (patch)
tree9110a1a00ffb0d9074d823cdc4aa5ef459eb84ac /x11
parentf09ef785735c98a80a99777b03780ed7d9bf914d (diff)
downloadfreebsd-ports-gnome-0885e720fa63eee312662781c808ebeae807c73d.tar.gz
freebsd-ports-gnome-0885e720fa63eee312662781c808ebeae807c73d.tar.zst
freebsd-ports-gnome-0885e720fa63eee312662781c808ebeae807c73d.zip
- Fix the build with OS-native (FreeBSD) AGP support
- Correct textual typo in comments while here
Diffstat (limited to 'x11')
-rw-r--r--x11/nvidia-driver/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index 72bbc1e783d4..c9ee0b71092d 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -36,7 +36,7 @@ OPTIONS= FREEBSD_AGP "Use FreeBSD AGP GART driver" off \
# `x11/nvidia-driver-71xx' or `x11/nvidia-driver-96xx' slave ports.
#
# NVidia played it tricky with their versioning scheme once again. To make
-# stable and legacy versions comprable, employ some sad ugly hackery: assign
+# stable and legacy versions comparable, employ some sad ugly hackery: assign
# NVVERSION for slave ports independently of master. Hopefully, this is a
# temporary measure and will go away soon.
#
@@ -106,6 +106,11 @@ post-patch: .SILENT
${REINPLACE_CMD} -e '15s,^,#include <sys/priv.h>,' \
${WRKSRC}/src/nvidia_os.c
.endif
+# Correct prototypes to fix the build with FreeBSD AGP support
+.if ${NVVERSION} == 1690700
+ ${REINPLACE_CMD} -e '337,338s/(/(nv_stack_t *, /' \
+ ${WRKSRC}/src/nv-freebsd.h
+.endif
.if defined(WITH_FREEBSD_AGP)
${REINPLACE_CMD} -E 's/undef (NV_SUPPORT_OS_AGP)/define \1/' \
${WRKSRC}/src/nv-freebsd.h