aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-27 00:29:44 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-27 00:29:44 +0800
commit08dc43f5c1506cb1682ef311699d480897626365 (patch)
tree846bb828c0342de7a914f4dec21179e225e957c6 /x11
parentc7ead94ea0c8170bd35108a780eac2854f87c517 (diff)
downloadfreebsd-ports-gnome-08dc43f5c1506cb1682ef311699d480897626365.tar.gz
freebsd-ports-gnome-08dc43f5c1506cb1682ef311699d480897626365.tar.zst
freebsd-ports-gnome-08dc43f5c1506cb1682ef311699d480897626365.zip
- Fix build for disabled NLS case
- Switch to options helpers - Simplify stripping - Simplify plist handling PR: 202076 Reported by: sascha@root-login.org Approved by: maintainer timeout (horia@racoviceanu.com, 9 months)
Diffstat (limited to 'x11')
-rw-r--r--x11/lxpanel/Makefile25
-rw-r--r--x11/lxpanel/pkg-plist2
2 files changed, 6 insertions, 21 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index ded97e8d4ba8..39a8f087106a 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -26,7 +26,7 @@ USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" \
--with-plugins=netstatus,volume,volumealsa,deskno,batt,kbled,xkb,thermal,cpu,cpufreq,monitors,wnckpager \
- --with-x \
+ --with-x --disable-silent-rules \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -I${WRKSRC}
@@ -41,14 +41,7 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ENABLE= alsa
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MALSA}
-PLIST_SUB+= VOLUME="@comment "
-.else
-PLIST_SUB+= VOLUME=""
-.endif
+NLS_USES_OFF= gettext-tools
post-patch:
@${REINPLACE_CMD} -e '/g_thread_create/ \
@@ -105,22 +98,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|linux|sys|' \
${WRKSRC}/src/plugins/volume/volume-impl.c
-.if ! ${PORT_OPTIONS:MNLS}
+post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|po man|man|' \
${WRKSRC}/Makefile.in
-.endif
post-install:
-.for l in netstatus deskno batt kbled xkb thermal cpu cpufreq monitors wnckpager
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lxpanel/plugins/${l}.so
-.endfor
-
-.if ${PORT_OPTIONS:MALSA}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lxpanel/plugins/volumealsa.so
-.else
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lxpanel/plugins/volume.so
-.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lxpanel/plugins/*.so
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/x11/lxpanel/pkg-plist b/x11/lxpanel/pkg-plist
index 3bdf08a5430e..26fd8a2564ca 100644
--- a/x11/lxpanel/pkg-plist
+++ b/x11/lxpanel/pkg-plist
@@ -9,7 +9,7 @@ lib/lxpanel/plugins/kbled.so
lib/lxpanel/plugins/monitors.so
lib/lxpanel/plugins/netstatus.so
lib/lxpanel/plugins/thermal.so
-%%VOLUME%%lib/lxpanel/plugins/volume.so
+%%NO_ALSA%%lib/lxpanel/plugins/volume.so
%%ALSA%%lib/lxpanel/plugins/volumealsa.so
lib/lxpanel/plugins/xkb.so
lib/lxpanel/plugins/wnckpager.so