aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-04 21:08:21 +0800
committerbapt <bapt@FreeBSD.org>2013-04-04 21:08:21 +0800
commit0b56de2f6316cdfaa39eaf1e2b4e912ed53f668f (patch)
treef5483a4ce26e2f5e15d8f7b540cc6fd84f073deb /x11
parent14122e3b2a4d93f1d6fd30f2550f4cc9a741c592 (diff)
downloadfreebsd-ports-gnome-0b56de2f6316cdfaa39eaf1e2b4e912ed53f668f.tar.gz
freebsd-ports-gnome-0b56de2f6316cdfaa39eaf1e2b4e912ed53f668f.tar.zst
freebsd-ports-gnome-0b56de2f6316cdfaa39eaf1e2b4e912ed53f668f.zip
Fix build with nls unset. the extra locale directories are created anyway.
While here: - Convert WITHOUT_NLS -> NLS option - Trim headers - Convert gnomehack -> USES=pathfix Approved by: x11 (zeising) Approved by: portmgr (implicit)
Diffstat (limited to 'x11')
-rw-r--r--x11/xkeyboard-config/Makefile21
-rw-r--r--x11/xkeyboard-config/pkg-plist10
2 files changed, 15 insertions, 16 deletions
diff --git a/x11/xkeyboard-config/Makefile b/x11/xkeyboard-config/Makefile
index d23fcabca085..615968b03e01 100644
--- a/x11/xkeyboard-config/Makefile
+++ b/x11/xkeyboard-config/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xkeyboard-config
-# Date Created: Dec 20 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
+# Created by: Florent Thoumie <flz@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xkeyboard-config
PORTVERSION= 2.5.1
@@ -18,9 +14,10 @@ BUILD_DEPENDS= xkbcomp:${PORTSDIR}/x11/xkbcomp \
xsltproc:${PORTSDIR}/textproc/libxslt
XORG_CAT= data
+USES= pathfix
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= intlhack gnomehack
+USE_GNOME= intlhack
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-xkb-base=${PREFIX}/share/X11/xkb \
@@ -30,16 +27,18 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN7= xkeyboard-config.7
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_ICONV= yes
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
CONFIGURE_ENV+= MSGFMT="/bin/echo '(GNU '" \
XGETTEXT="/bin/echo '(GNU '" \
MSGMERGE="/bin/echo '(GNU '"
PLIST_SUB+= NLS="@comment "
-.else
-USE_ICONV= yes
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
post-patch:
diff --git a/x11/xkeyboard-config/pkg-plist b/x11/xkeyboard-config/pkg-plist
index 14e616665b59..b36678ff3000 100644
--- a/x11/xkeyboard-config/pkg-plist
+++ b/x11/xkeyboard-config/pkg-plist
@@ -366,11 +366,11 @@ share/X11/xkb/types/pc
%%NLS%%share/locale/vi/LC_MESSAGES/xkeyboard-config.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xkeyboard-config.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xkeyboard-config.mo
-%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/rw
-%%NLS%%@dirrmtry share/locale/ky/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ky
-%%NLS%%@dirrmtry share/locale/crh/LC_MESSAGES
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/crh/LC_MESSAGES
@exec mkdir -p /var/lib/xkb
@dirrmtry share/locale/crh
@dirrm share/X11/xkb/types