aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-11-13 16:47:51 +0800
committerBoris Samorodov <bsam@FreeBSD.org>2013-11-13 16:47:51 +0800
commit1715bb221ae7d2d3db40e2a122bba9efdb836a2f (patch)
treecea55eaf2f7b47970d6a99db03252e96872d717f /x11
parent0796d28a7dadb562b16a867d0b59174290eb5a79 (diff)
downloadfreebsd-ports-gnome-1715bb221ae7d2d3db40e2a122bba9efdb836a2f.tar.gz
freebsd-ports-gnome-1715bb221ae7d2d3db40e2a122bba9efdb836a2f.tar.zst
freebsd-ports-gnome-1715bb221ae7d2d3db40e2a122bba9efdb836a2f.zip
. increase CPU granularity from 1 sec. to 2 sec. to get more smooth results
(the same difference as with "top -s1" vs "top -s2", look at idle state); . bump PORTREVISION.
Diffstat (limited to 'x11')
-rw-r--r--x11/fbpanel/Makefile2
-rw-r--r--x11/fbpanel/files/patch-plugins__cpu__cpu.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index 70f31822691e..d7422da1e6a3 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fbpanel
PORTVERSION= 6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= SF
EXTRACT_SUFX= .tbz2
diff --git a/x11/fbpanel/files/patch-plugins__cpu__cpu.c b/x11/fbpanel/files/patch-plugins__cpu__cpu.c
index 8c50bd994d13..6d78053ace25 100644
--- a/x11/fbpanel/files/patch-plugins__cpu__cpu.c
+++ b/x11/fbpanel/files/patch-plugins__cpu__cpu.c
@@ -82,3 +82,12 @@
#else
static int
cpu_get_load(cpu_priv *c)
+@@ -109,7 +173,7 @@
+ k->set_rows(&c->chart, 1, c->colors);
+ gtk_widget_set_tooltip_markup(((plugin_instance *)c)->pwid, "<b>Cpu</b>");
+ cpu_get_load(c);
+- c->timer = g_timeout_add(1000, (GSourceFunc) cpu_get_load, (gpointer) c);
++ c->timer = g_timeout_add(2000, (GSourceFunc) cpu_get_load, (gpointer) c);
+ RET(1);
+ }
+